Desktop productivity for business analysts and programmers

Turning off goptions in SAS EG code node

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

Turning off goptions in SAS EG code node

We switched over to sas grid on linux and left the local windows server without sas graph so there is an error every time the code node is run. Suggestions on how to turn off the goptions? It doesnt keep the node from running but it does through an error everytime you run anything in code node.

14        GOPTIONS XPIXELS=0 YPIXELS=0;           ________           180 ERROR 180-322: Statement is not valid or it is used out of proper order. 26        GOPTIONS ACCESSIBLE;           ________           180 ERROR 180-322: Statement is not valid or it is used out of proper order.


Accepted Solutions
Solution
‎10-23-2014 03:26 PM
Community Manager
Posts: 2,711

Re: Turning off goptions in SAS EG code node

Yes, you'll find the setting in Tools->Options, under Results: Graph.

Screenshot:

goption.png

Chris

View solution in original post


All Replies
Solution
‎10-23-2014 03:26 PM
Community Manager
Posts: 2,711

Re: Turning off goptions in SAS EG code node

Yes, you'll find the setting in Tools->Options, under Results: Graph.

Screenshot:

goption.png

Chris

New Contributor
Posts: 4

Re: Turning off goptions in SAS EG code node

Thank you sir!

Community Manager
Posts: 2,711

Re: Turning off goptions in SAS EG code node

You're welcome! And welcome to the community -- keep those questions (and maybe even some answers...) coming!

Chris

New User
Posts: 1

Re: Turning off goptions in SAS EG code node

Hi, I tried your solution by turning off goptions under Graph, I still got the same error.

ERROR 180-322: Statement is not valid or it is used out of proper order.

 

Any idea?

Community Manager
Posts: 2,711

Re: Turning off goptions in SAS EG code node

Hi @yanmy325, can you post your entire log?  Or at least the portion around the error?  It seems like something else must be going on.

Occasional Contributor
Posts: 5

Re: Turning off goptions in SAS EG code node

Goptions error occurs in the log file when SAS/GRAPH is not installed on the server, or the license doesn't give SAS/GRAPH product.

 

 

Community Manager
Posts: 2,711

Re: Turning off goptions in SAS EG code node

Are you having this problem? The solution in this thread should fix it for you.
☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 6720 views
  • 2 likes
  • 4 in conversation