Desktop productivity for business analysts and programmers

Some graph titles no longer appearing when program run in EG

Reply
New Contributor
Posts: 2

Some graph titles no longer appearing when program run in EG

I created a dashboard in EG 4.1 using code from the following SAS site: http://support.sas.com/rnd/datavisualization/dashboards/ We have individual installs of PC SAS 9.1.2 for Windows (yeah kind of old) and EG 4.1.0.471.

I used the slider bar indicators SAS program code as the starting point for building the dashboard - modified it some and added additional SAS/Graph code so the dashboard consists of two slider bars, a pie chart, vertical bar chart, line chart and double bar chart.

I've run the dashboard project fine for 3 weeks, then last week when I ran the project the titles above the two slider bars no longer were showing. The titles above the other charts are fine. One other change also appeared in the output when the titles stopped appearing - the titles and other text in the pie, vertical bar, and line chart had been black but changed to a redish color. This didn't happen in the double bar chart or the slider bars.

I figured the EG dashboard project got corrupted somehow - but when I download the original SAS slider bar program and run it with EG, the slider bar titles don't appear in that output either. [ I downloaded and run the Bar Chart Indicators program from the SAS site and the titles that should be above each bar chart do not appear.]

But if I run the program using PC SAS (not through EG), the titles appear. I just reinstalled EG 4.1 and that didn't fix the problem. I got a co-worker to run the SAS Slider Indicator code on his PC in EG and the titles do appear.

Any thoughts of what happened? Thanks.
Community Manager
Posts: 2,712

Re: Some graph titles no longer appearing when program run in EG

Try looking at your Tools->Options->Results settings, especially the graph settings. Could be that the title behavior (whether to include in the chart or not) has been set to something different (equates to NOGTITLE or GTITLE option on the ODS statement).

You might try just clicking Reset Options to default, and see if that helps clear it up.

Chris
New Contributor
Posts: 2

Re: Some graph titles no longer appearing when program run in EG

That was it Chris. Checked in Tools->Options->Results->Graph, then selected GIF under Graph Format since the GREPLAY procedure creates the dashboard as a GIF file. The box for 'Include titles inside the image' was not checked. Once I checked it and ran the program again, the titles are back.

Thank you.

Bruce
Community Manager
Posts: 2,712

Re: Some graph titles no longer appearing when program run in EG

You can always force that in the program by adding your own OPTIONS DEV=GIF; statement, overriding what EG generates in its "ODS sandwich".

Chris
Contributor
Posts: 28

Re: Some graph titles no longer appearing when program run in EG

Hi...

I have a similiar problem in EG with the PROC Freq Titles...

I'm trying to surpress it saying The FREQ Procedure... but I do want my TITLE to show..

I changed the setting in the Options under TASKS GENERAL -- I unchecked "Include SAS procedure titles in results" ... but they are still showing...???   Any suggestions?

Thanks!!

Contributor
Posts: 45

Re: Some graph titles no longer appearing when program run in EG

even after re-running the task?

Ask a Question
Discussion stats
  • 5 replies
  • 182 views
  • 0 likes
  • 4 in conversation