Desktop productivity for business analysts and programmers

SAS EG4.1 AND BI server 9.3.1 of AIX 5.3

Reply
N/A
Posts: 0

SAS EG4.1 AND BI server 9.3.1 of AIX 5.3

Hi I'm Sung Joon yi of Bank of Korea
I use EG 4.1 connected on BI Sever of AIX 5.3
Recently I tried the codes belows:

ods html;
ods graphics on;

title "Illustration of ODS Graphics";
proc timeseries data=sashelp.workers out= test
crossplot=all;
id date interval=month;
var electric;
crossvar masonry;
run;

ods graphics off;
ods html close;

but error occured with message
"ERROR: Java class generated an exception."
and then plot image did not appeared.

I also recevied a solution which made by sas of Korea:

"Add two statement into sasenv file belows
DISPLAY=:0
export DISPLAY
"
But this did not work either

Thanks for your reply in advance
Super Contributor
Posts: 260

Re: SAS EG4.1 AND BI server 9.3.1 of AIX 5.3

Hi.

I don't know if your problem is the same, but maybe your java (JRE) version on the server is not the one that SAS is expecting (SAS 9.1.3 requires JRE 1.4.2_09). If your JRE version is 2 or higher, it can cause some trouble when using ODS GRAPHICS.

How does one check the JRE version on AIX ? This is far beyond my skills !
Community Manager
Posts: 2,882

Re: SAS EG4.1 AND BI server 9.3.1 of AIX 5.3

You can check the version of Java configured for your SAS server by running this SAS program:
[pre]
proc javainfo; run;
[/pre]
Chris
Ask a Question
Discussion stats
  • 2 replies
  • 112 views
  • 0 likes
  • 3 in conversation