Desktop productivity for business analysts and programmers

SAS EG file created in 5.1 version not opening in SAS EG 4.3

Reply
Occasional Contributor
Posts: 6

SAS EG file created in 5.1 version not opening in SAS EG 4.3

Hello,

I have been working on SAS EG 5.1 version and have all my .egp packages created.When I try to open them in SAS EG 4.3 i get the following two errors:

1) When I open my SAS EG 4.3 version an error message is displayed which is :

System.IO.FileNotFoundException

Could not load file or assembly 'Microsoft.Web.Services3, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

------------------------------ Technical Information Follows ------------------------------

System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Web.Services3, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

File name: 'Microsoft.Web.Services3, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

   at SAS.EG.SDS.Model.OMBase.FlushDAV()

   at SAS.EG.SDS.Model.Broker.Clear()

   at SAS.EG.SDS.Model.Broker.OnProviderConnected(Object sender, Provider p)

   at SAS.EG.SDS.Metadata.ProviderConnectionDelegate.Invoke(Object sender, Provider provider)

   at SAS.EG.SDS.Metadata.MetadataManagerV2.FireProviderConnected(Provider provider)

   at SAS.EG.SDS.Metadata.NullProvider.Connect()

   at SAS.EG.SDS.Metadata.MetadataManagerV2.SAS.EG.SDS.Metadata.IMetadataConfiguration.set_ActiveProvider(Provider value)

   at SAS.EG.ProjectElements.MetadataHelper.SetActiveProvider(Provider provider)

   at SAS.EG.SEGuide.MainForm.ConnectToRepository(Provider provider)

   at SAS.EG.SEGuide.MainForm.OnAppLoaded()

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

2) After I click OK and try to open .egp package in version 4.3 (which was created in SAS EG 5.1) I get the error the message :

"Unable to Open file "F:\AnE.egp" .The project file version not supported or from a later version"

Can somebody please help me? Are these two errors interconnected.

Is it that we cant open SAS EG project (created in 5.1) version in 4.3 version?

Is there any wayaround to open SAS EG project in 4.3 version (which is created in 5.1 version).My project opens fine in 5.1 version.


Please help if anyone knows about this issues.

Also have attached the error messages with this query


Thanks,

Tejas


SAS_EG.jpgErro1.jpg
Valued Guide
Posts: 3,208

Re: SAS EG file created in 5.1 version not opening in SAS EG 4.3

IT is very usual to have no access of newer formats with older versions. It are exceptions when it works .

That is a statement for all uses tooling not just SAS. You erromessage is also telling you this.

The error is to be expected, working as designed.   

Eguide is changed with 5.1.  SAS(R) 9.3 Guide to Software Updates (SAS Enterprise Guide 5.1)

What is your real problem?

---->-- ja karman --<-----
Occasional Contributor
Posts: 6

Re: SAS EG file created in 5.1 version not opening in SAS EG 4.3

Hi Jaap Karman,

Thanks for your reply.

My real problem is: I have done SAS EG projects in SAS EG 5.1 version and I want to run those projects is SAS EG 4.3 version (client machine).Now when I try to open the projects in SAS EG 4.3 it gives message "Unable to Open file "F:\AnE.egp" .The project file version not supported or from a later version".

Is their any way I can open the project which is created in SAS EG 5.1 version in EG 4.3 version or somehow downgrade my work to run in EG 4.3 version so my project can run.

Otherwise I have to rewrite my whole code again Smiley Sad.

PS: I am using desktop version of SAS for my projects. (i.e both SAS EG 5.1 and SAS EG 4.3 are desktop version)

Valued Guide
Posts: 3,208

Re: SAS EG file created in 5.1 version not opening in SAS EG 4.3

The Eguide is running on Windows Desktop and has requirements to windows.

http://support.sas.com/documentation/installcenter/en/ikeguidesr/64672/PDF/default/sreq.pdf (sysreq eg4.3)

http://support.sas.com/documentation/installcenter/en/ikeguidesr/65195/PDF/default/sreq.pdf (sysreq eg5.1)

The error message you have got while opening the eg-project is indicating some missing parts on windows.   

It looks to be EG 4.3 is trying to open/use something triggered within the project, and .... grr

MS webservices 3... error.

That is one of there requirements for 4.3 Eguide not mentioned with 5.1. 

Is the 4.3 installation working with an fresh new project? (your eguide 4.3 installation being corrupted)  

According to ChrisH notes Eg 5.1 is able to run with older versions SAS.

SAS Enterprise Guide versions and SAS 9.4: what&#8217;s supported - The SAS Dummy

Looks to be the most easy approach is: upgrade your desktop EGuide version to 5.1

---->-- ja karman --<-----
Occasional Contributor
Posts: 6

Re: SAS EG file created in 5.1 version not opening in SAS EG 4.3

Thanks for the reply. I was able to fix the issue of 4.3 Eguide earlier only I referred to 37262 - An exception occurs when you invoke SAS® Enterprise Guide® 4.2  

document and the issue is sorted. So I am having a error free SAS EG 4.3 version.

Regarding the backward compatibility check I also found two anwers of Chris H stating its not possible to downgrade work of EG to lower version.

1) https://communities.sas.com/thread/35219?start=0&tstart=0

2) Frequently asked questions about SAS 9.3 and SAS Enterprise Guide - The SAS Dummy

The problem is i cant upgrade to SAS EG 5.1 due to policies so was looking around for ways to covert the code to a lower version.(4.3 version I am looking for)

Valued Guide
Posts: 3,208

Re: SAS EG file created in 5.1 version not opening in SAS EG 4.3

Let me summarize:

- regression of 5.1 egp files to 4.3 is not to be expected to be delivered by SAS-institute

- Your company Policies on desktop (and many more) prohibit it updating it yourself.  a very common situation.

- Your IT support is not capable or not wanting to deliver multiple version as MS-package options in a quick way (say weeks).

  The approach of SAS institute of the SAS-Software depot dogma for installing SAS software on desktops could be te real problem.

  This approach is not aligned with many common procedures within IT. You could transform some things with some knowledge.    

Your real question is: How to solve this dilemma "Local IT-staff" vs "SAS" as you have to deal with the resulting effects.
As it is a very recognizable situation, thanks for sharing, the only thing we can do is giving signals.

Hoping some people are giving a response to get something changed.

Hopeless? may be not.

With 9.4 SAS made the promise to deliver msi-approaches for Eguide/Amo.

The bad thing is they are requiring a 64-bit environment for Eguide 6.1.    

---->-- ja karman --<-----
Ask a Question
Discussion stats
  • 5 replies
  • 3953 views
  • 0 likes
  • 2 in conversation