Desktop productivity for business analysts and programmers

SAS EG 7.1 Windows 10 64bit - A connection to the server "Local" could not be established

Accepted Solution Solved
Reply
Contributor
Posts: 21
Accepted Solution

SAS EG 7.1 Windows 10 64bit - A connection to the server "Local" could not be established

Dear SAS Communities,

im trying to install SAS EG to my colleague, I've done it many times already. But this one seems like a problem

OS: W10

SAS EG v 7.1

 

Problem:

Base SAS (sas.exe) Works fine, Licence on EG is to 2018JUN

 

BUT

 

Enterprise guide says this when submitting code:

"A connection to the server "Local" could not be established"

Conf details from "about sas":

--- SAS Software ---
  SAS Enterprise Guide version: 7.100.0.2002
  SAS System version: 9402.0.21456.22399
  SAS System Command: c:\progra~1\sashome\sasfou~1\9.4\sas.exe -config "c:\program files\sashome\sasfoundation\9.4\sasv9.cfg"  -objectserver -nologo -noterminal -noprngetlist
  SAS Shared Files: C:\Program Files\SASHome
  JMP Installation:
--- Current Process ---
  Current directory: C:\Program Files\SASHome\SASEnterpriseGuide\7.1
  Command line: "C:\Program Files\SASHome\SASEnterpriseGuide\7.1\SEGuide.exe"
  Temporary files location: C:\Users\Kateřina\AppData\Local\Temp\SEG7360
  Memory used: 276,881,408 bytes
  Client session type: Running on console
  Running in WOW64 (32-bit subsystem): No
  Running as a 64 bit process: Yes
--- Operating System ---
  Name: Windows 8
  Version: 6.2.0.9200
  Service pack: No Service Pack Installed
  .NET Runtime Version: 4.0.30319.42000 (no service pack)
  Internet Explorer version: 9.11.14393.0
  System directory: C:\Windows\system32
  Default web browser: Launch Windows App
  MDAC version: 6.3.9600.16384
  WPF Render Capability Tier: 0x20000
--- User ---
  User name:
  User ID: Kateřina
  Machine name: DESKTOP-5LSNPU9
--- Active Metadata Connection Profile ---
  Profile name: Null Provider
  Description:
  Host name:
  Port:
  Default server:
  Person name: PUBLIC
  Authentication type: IWA
  Using Integrated Windows Authentication: True
  Security package: Negotiate
  Security Package List: Kerberos,NTLM
  Service principal name:
  User:
  Password set: not specified
  Save login: True
  Connected: True
--- Metadata Server Status ---
  Platform version:
  Model version:
  Server locale:
  Server state:
  Pause comment:

 

I also tried to test local server by running "C:\Program Files\SASHome\x86\Integration Technologies\ITConfig2.exe" utility, which led to this result (her username in windows is Kateřina, which might be the problem)

Could be the main problem with her windows username (i believe that "ř" is in utf-8)?

 

 

Failed to transcode data from utf-8 to utf-16le encoding because it contained characters which are not supported by your SAS session encoding.  Please review your encoding= and locale= SAS system options to ensure that they can accommodate the data that you want to process.  A portion of the source string, in hex representation is:
59a9ed4: 4b 61 74 65 f8 69 6e 61                         |Kate.ina        |

 

When i try to expand "Local" server in EG, it says this

 

Provádění serveru selhalo

 

-------------------------- Technical Information Follows --------------------------

Exception Details:
----------------------------------------
Exception type:  SAS.EG.SDS.SDSException
Message:        Server execution failed

Source:          SAS.EG.SDS.Model
Target Site:     SASWorkspace

Stack Trace:
   at SAS.EG.SDS.Model.Server.SASWorkspace()
   at SAS.EG.SDS.Views.View.DoPopulate(DisplayOperation& op)

Inner Exception Details:
----------------------------------------
Exception type:  SAS.EC.Directory.Model.SDSException
Message:         Server execution failed

Source:          EC.Directory
Target Site:     Connect

Inner Exception Details:
----------------------------------------
Exception type:  System.Runtime.InteropServices.COMException
Message:         Provádění serveru selhalo

Source:          SASObjectManager
Target Site:     CreateObjectByServer

Stack Trace:
   at SASObjectManager.ObjectFactoryMulti2Class.CreateObjectByServer(String Name, Boolean synchronous, IServerDef pIServerDef, String LoginName, String Password)
   at SAS.EC.Directory.Model.Server.Connect(ConnectionInfo connInfo)

 

Many many thanks for your help, already tried to reinstall whole solution 3 times...

Have a nice day,

Michal

 

 


Accepted Solutions
Solution
‎09-25-2017 10:26 AM
SAS Super FREQ
Posts: 376

Re: SAS EG 7.1 Windows 10 64bit - A connection to the server "Local" could not be establis

[ Edited ]

Yeah, if you aren't able to connect to the server using the "C:\Program Files\SASHome\x86\Integration Technologies\ITConfig2.exe" utility, you won't be able to connect to it from EG either (since EG uses the same underlying technology to communicate with SAS servers... Integration Technologies).  As you mentioned, yes, it does appear to be an issue with the non-standard character (LATIN SMALL LETTER R WITH CARON) in the username.  That character is C5 99 in UTF8, but the "failed to transcode" error message you shared shows it as "f8" (I don't currently have an explanation for that).  You may need to change the session encoding of your locally registered COM server (Local) to an encoding that supports that character.

 

One of my colleagues just pointed out it looks like you might be using this encoding... (Latin-2) https://en.wikipedia.org/wiki/ISO/IEC_8859-2, since it uses F8 for that character.

View solution in original post


All Replies
Contributor
Posts: 21

Re: SAS EG 7.1 Windows 10 64bit - A connection to the server "Local" could not be establis

"Provádění serveru selhalo" is just "Server execution failed" in czech Smiley Happy

Contributor
Posts: 21

Re: SAS EG 7.1 Windows 10 64bit - A connection to the server "Local" could not be establis

i also tried

sas.exe /unregserver

sas.exe /regserver

Solution
‎09-25-2017 10:26 AM
SAS Super FREQ
Posts: 376

Re: SAS EG 7.1 Windows 10 64bit - A connection to the server "Local" could not be establis

[ Edited ]

Yeah, if you aren't able to connect to the server using the "C:\Program Files\SASHome\x86\Integration Technologies\ITConfig2.exe" utility, you won't be able to connect to it from EG either (since EG uses the same underlying technology to communicate with SAS servers... Integration Technologies).  As you mentioned, yes, it does appear to be an issue with the non-standard character (LATIN SMALL LETTER R WITH CARON) in the username.  That character is C5 99 in UTF8, but the "failed to transcode" error message you shared shows it as "f8" (I don't currently have an explanation for that).  You may need to change the session encoding of your locally registered COM server (Local) to an encoding that supports that character.

 

One of my colleagues just pointed out it looks like you might be using this encoding... (Latin-2) https://en.wikipedia.org/wiki/ISO/IEC_8859-2, since it uses F8 for that character.

SAS Employee
Posts: 199

Re: SAS EG 7.1 Windows 10 64bit - A connection to the server "Local" could not be establis

Hi @miki7

 

As per the log, you're using 7.100.0.2002.

Usage Note 54938 (Hot Fix release numbers for SAS® Enterprise Guide® 7.1, 7.11, 7.12, and 7.13) informs us this is EG7.1 HF1.

Unfortunately, with Windows 10, you need to use at least EG7.12 (cf Installation Note 38120 Support for SAS® Add-In for Microsoft Office in Microsoft Office 2016, 2013, and 2010).

 

You may want to ask fopr a new Order.

 

Cheers,

Damo

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 1057 views
  • 0 likes
  • 3 in conversation