Desktop productivity for business analysts and programmers

Running program on Enterprise Guide - stuck at "Connecting to server", but server is local

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 8
Accepted Solution

Running program on Enterprise Guide - stuck at "Connecting to server", but server is local

Sometimes when using SAS EG 7.13 I try to run a program and the task status panel shows "Status: Connecting to server". I'm using a local server, connecting to data sets on a network drive. It gets stuck at this point and will not continue. I have tried restarting the PC but this does not help. I have tried multiple programs in different projects and none of them run. If I run the program from another PC it works fine. 

 

What causes this problem and how can I fix it? Thanks in advance.


Accepted Solutions
Solution
‎03-19-2018 11:09 PM
PROC Star
Posts: 1,334

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

Ah, that gives us another line to pursue.

 

Since the SAS instance is on your local machine, when you try to stop a query and it doesn't stop it means that very likely the local SAS instance is still chugging away, which may be consuming TONS of your machines resources.

 

The next time this happens, try opening Task Manager, and look for the "SAS 9.4 for Windows" (or something similar) background task.End that task, which will kill whatever SAS was doing. When you start up EG the next time, it will start a new SAS task.

 

Tom

View solution in original post


All Replies
Super User
Posts: 4,028

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

If its working fine on another computer then there must be something different about the setup of your computer that is causing the problem. How do you link to the the network drives where your data is stored? Do you map drive letters or to you point to the drive using a file share like \\MyFileServer\MyFolder?

Occasional Contributor
Posts: 8

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

Fortunately/unfortunately I've returned to work the following day and it's all working now. However, this is a reoccurring problem so I'm still interested in what problem-solving techniques I should be using next time.

 

To answer your question, although the drives are mapped to a letter, the libname is defined using what you've described as a file share (the path starts with \\). Is one of these ways better than another?

PROC Star
Posts: 1,334

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

Since EG is just running SAS on your local computer, try bringing up SAS standalone, and see if the log gives you any indications.

 

Tom

Occasional Contributor
Posts: 8

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

I'm still new to SAS so I wasn't aware this was an option. As I mentioned in another reply I'm back at work the following day and it's now working, but this is a reoccurring problem I'd like to know how to fix.

Do I just open up the "SAS 9.4" program and look at the log window? It doesn't appear to show anything when running a program in SAS EG. What should I be looking for?
PROC Star
Posts: 1,334

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

Yes, that's exactly correct. It's just something to rule out.

 

For example, it used to be the case that if your SAS license had expired, you'd get no information to that effect by starting up EG, but starting up SAS would display a clear message.

 

Intermittent problems are a royal pain! How often is it happening?

 

Tom

Occasional Contributor
Posts: 8

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

My work has only recently upgraded to Windows 10, and I didn't have an issue before then, but I was using SAS EG 5 and now I'm on 7 with SAS 9.4 so there are a few things that have changed since when it worked fine. I've had it happen three times in the last month or so.

Other possibly relevant information is it seems to start (2/3 times) when I try to stop a query and it won't stop cleanly. Possibly the server gets locked up in some way? Or on the other hand maybe it's not stopping cleanly because the issue has already started.
Solution
‎03-19-2018 11:09 PM
PROC Star
Posts: 1,334

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

Ah, that gives us another line to pursue.

 

Since the SAS instance is on your local machine, when you try to stop a query and it doesn't stop it means that very likely the local SAS instance is still chugging away, which may be consuming TONS of your machines resources.

 

The next time this happens, try opening Task Manager, and look for the "SAS 9.4 for Windows" (or something similar) background task.End that task, which will kill whatever SAS was doing. When you start up EG the next time, it will start a new SAS task.

 

Tom

Occasional Contributor
Posts: 8

Re: Running program on Enterprise Guide - stuck at "Connecting to server", but server is l

That's great info, thanks! Next time I have an issue, this is the first thing I'll try. Thanks for the help!
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 8 replies
  • 268 views
  • 0 likes
  • 3 in conversation