Desktop productivity for business analysts and programmers

Problem with the import of a database 5.1 version

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 17
Accepted Solution

Problem with the import of a database 5.1 version

Hi to everybody. I have a little problem with the import of a Database. The database have MM 4.2 of lines, but the import task only make MM 4.08 of lines. In the version 4.1 I never had a problem, but a weeks ago it was upgrade to 5.1. I don't know what is the problem.

Thanks in advance for your help.

Regards,

Francisco.


Accepted Solutions
Solution
‎12-18-2013 08:49 AM
Community Manager
Posts: 2,882

Re: Problem with the import of a database 5.1 version

If you think that Enterprise Guide is somehow "dropping" records, you can try to tune the process a bit.

First, make sure the encoding is correct.  I see you're running EG in Spanish, and the Windows-1252 encoding should be fine for your data (assuming it contains only the latin-1 characters), but that's something you can double-check.

Second, you can remove EG's "cleansing" step -- the step where it prepares a "clean" version of your data file before importing it.  To do this, click the Performance button (Rendimiento in your Spanish interface), and then check the second option on that window.  In English it's "Bypass the data cleansing process".  This should cause EG to pass your raw text file "as is" to the server session for import.

Chris

View solution in original post


All Replies
Community Manager
Posts: 2,882

Re: Problem with the import of a database 5.1 version

Hi Francisco,

We'll need a few more details.  What form is the database?  Is it an Excel file, CSV file, or MS Access?

Can you share more information about how the import is working?  Screen shots of the import data task, etc.

If you can't share that on the forum, you may need to track with SAS Technical Support instead.

Chris

Occasional Contributor
Posts: 17

Re: Problem with the import of a database 5.1 version


Hi Chris. Thanks for your response. This DB is a txt file and the size is 1.5 GB. I attached log, code, step by step of the import and example of the register of the DB.

Thanks in advance for your help.

Best,

Attachment
Attachment
Solution
‎12-18-2013 08:49 AM
Community Manager
Posts: 2,882

Re: Problem with the import of a database 5.1 version

If you think that Enterprise Guide is somehow "dropping" records, you can try to tune the process a bit.

First, make sure the encoding is correct.  I see you're running EG in Spanish, and the Windows-1252 encoding should be fine for your data (assuming it contains only the latin-1 characters), but that's something you can double-check.

Second, you can remove EG's "cleansing" step -- the step where it prepares a "clean" version of your data file before importing it.  To do this, click the Performance button (Rendimiento in your Spanish interface), and then check the second option on that window.  In English it's "Bypass the data cleansing process".  This should cause EG to pass your raw text file "as is" to the server session for import.

Chris

Occasional Contributor
Posts: 17

Re: Problem with the import of a database 5.1 version

Thanks a lot Chris!!! I solve the problem.

Thanks for your time and happy xmas.

Best,

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 399 views
  • 0 likes
  • 2 in conversation