Desktop productivity for business analysts and programmers

Problem with apostrophe

Reply
Occasional Contributor
Posts: 13

Problem with apostrophe

Hi
I have a problem where I need to read in excel file in to EG. This file excel file has names of organizations and some of names have apostrophe (').
Ex. Kids' Organization Inc.
So I get following warning
WARNING: The quoted string currently being processed has become more than 262 characters long. You may have unbalanced quotation marks.

Any suggestions how I might avoid this problem.
Valued Guide
Posts: 2,111

Re: Problem with apostrophe

What version of EGuide and SAS? The method of reading Excel changed from 4.1 to 4.2. Also, are you working with the Excel file in place or converting it to a SAS dataset; those choices also affect how the file is read.
Occasional Contributor
Posts: 13

Re: Problem with apostrophe

My EG is version 4.2, and the SAS version is 9.2

And concerning the reading in the file. I am attempting to make the excel file in to a SAS dataset. That way I can use it whenever I need it.
Valued Guide
Posts: 2,111

Re: Problem with apostrophe

I used
Open --> data
pointed to the spreadsheet, and it imported fine (using 4.2 and 9.2 TS2M2).

You may need to open a track with tech support.
N/A
Posts: 0

Re: Problem with apostrophe

Hi Bigz,
Can you try ...tools - options - sas programs

Under additional SAS code -- check insert custom SAS code before submitting code and click edit.

Add the following line
options validvarname=v7;


then try to read excel file in EG. lemme know how it goes.
SAS Employee
Posts: 149

Re: Problem with apostrophe

I believe in version 4.2, on the last screen of the wizard there are a couple options about removing problem characters or putting the values into the code itself. You might try one or both of those to see if it resolves the problem. Maybe not... but that's the best I've got right now. Smiley Happy
Respected Advisor
Posts: 3,836

Re: Problem with apostrophe

Try in step 2 of the import wizard "Rename columns to comply with SAS naming conventions". That should resolve the issue.
Ask a Question
Discussion stats
  • 6 replies
  • 316 views
  • 0 likes
  • 5 in conversation