Desktop productivity for business analysts and programmers

Problem with SAS enterprise 4.2

Reply
New Contributor
Posts: 3

Problem with SAS enterprise 4.2

I am trying to open an existing SAS data set using the SAS enterprise 4.2. I have used this data set before, recently it started showing the following error:

" SAS Enterprise Guide has encountered a problem ans needs to close" : On restarting the application the same message comes up.

These are the details from the SAS error:

"

System.ArgumentOutOfRangeException

InvalidArgument=Value of '7' is not valid for 'index'.

Parameter name: index

------------------------------ Technical Information Follows ------------------------------

System.ArgumentOutOfRangeException: InvalidArgument=Value of '7' is not valid for 'index'.

Parameter name: index

   at System.Windows.Forms.ImageList.ImageCollection.get_Item(Int32 index)

   at SAS.EG.Controls.ProcessView._CreateToolStripItem(String text, Int32 imageIndex, EventHandler onClickHandler)

   at SAS.EG.Controls.ProcessView.InitializeControls()

   at SAS.EG.Controls.ProcessView..ctor()

   at SAS.EG.Controls.ProcessFlowView.InitializeCustom()

   at SAS.EG.Controls.ProcessFlowView..ctor()

   at SAS.EG.SEGuide.MainForm.CreateViews()

   at SAS.EG.SEGuide.MainForm..ctor(EGOptions startupOptions)

   at SAS.EG.SEGuide.App.Startup(String[] args)

   at SAS.EG.SEGuide.App.Main(String[] args)

------------------------------ End of Technical Information ------------------------------

Can someone help me in finding the solution to this problem?

Super Contributor
Posts: 349

Re: Problem with SAS enterprise 4.2

Hi,

Check this sample note.

http://support.sas.com/kb/42/296.html

Thanks,

Shiva

New Contributor
Posts: 3

Re: Problem with SAS enterprise 4.2

Thank you for the help Shiva. I am not sure if I am doing something wrong, but when I click on the link provided by you , it asks me to click on the hot fix tab in the message, but that tab is not clickable. Am I looking at the wrong hot fix tab?

Respected Advisor
Posts: 3,065

Re: Problem with SAS enterprise 4.2

That SAS note works fine for me. What web browser are you using? Can you try a different browser?

New Contributor
Posts: 3

Re: Problem with SAS enterprise 4.2

Thank you for the reply. SO, if I am looking at this correctly the error I have could be fixed by HOt fix numbered A53003. However I do not see a dowloadable file for that Hot Fix like I see for others like A53002 and A53004. Please correct me if I am wrong.

Respected Advisor
Posts: 3,065

Re: Problem with SAS enterprise 4.2

Download A53004 as previous hot fixes will be included in this bundle or alternatively use A53010 as this replaces A53003 as mentioned on the hot fix download page.

Ask a Question
Discussion stats
  • 5 replies
  • 691 views
  • 0 likes
  • 3 in conversation