Desktop productivity for business analysts and programmers

Prevent Auto-load of table in EG

Accepted Solution Solved
Reply
Contributor
Posts: 41
Accepted Solution

Prevent Auto-load of table in EG

When I select multiple tables and drag them to the project area, the icons for the tables show and I'm able to start working on the join statements, et al.  When I drag only one table to the project area, the table is automatically opened.  The data is often monstrous, so this is very time consuming as I have to wait for the sample rows to finally show.  Is there a way to turn this feature off?  I guess I could drag two tables over then delete one, but that's inefficient, too...

 

Your thoughts?
Thanks!

Rita Yee

Project Engineer, FedEx Express

___________________________________
The fact that I ask for help simply means I am inexperienced and under-educated. Please don't assume I am incompetent and uneducated.

Accepted Solutions
Solution
‎09-15-2017 04:25 PM
Frequent Contributor
Posts: 140

Re: Prevent Auto-load of table in EG

Rita,

 

Have you tried Tools, Options, Data, Data General?  There's a check box there that says "Automatically open data when added to project."  Try unchecking that box.

 

Jim

View solution in original post


All Replies
Solution
‎09-15-2017 04:25 PM
Frequent Contributor
Posts: 140

Re: Prevent Auto-load of table in EG

Rita,

 

Have you tried Tools, Options, Data, Data General?  There's a check box there that says "Automatically open data when added to project."  Try unchecking that box.

 

Jim

Contributor
Posts: 41

Re: Prevent Auto-load of table in EG

Posted in reply to jimbarbour

Bless you Smiley Happy

___________________________________
The fact that I ask for help simply means I am inexperienced and under-educated. Please don't assume I am incompetent and uneducated.
Contributor
Posts: 41

Re: Prevent Auto-load of table in EG

Posted in reply to jimbarbour

Well, I haven't tried it yet because my table is still trying to load.  Any suggestions on how I stop it without CTRL-ALT-DEL?? Smiley Happy

___________________________________
The fact that I ask for help simply means I am inexperienced and under-educated. Please don't assume I am incompetent and uneducated.
Community Manager
Posts: 3,463

Re: Prevent Auto-load of table in EG

I'm afraid you can't interrupt the table loading...  But, a slow-loading table is an indication of another problem.  Data -- even large data -- should not take that long to load into the data view, which reads only small batches of records at a time.  Unless the tables are extremely wide or are coming from a database/network location with high latency, you should not expect such a delay.

 

Making that better is usually a conversation with your SAS admin and maybe a database admin to see what can be done.  Might be a tweak on the library definition, or a different approach for how you access that data.

PROC Star
Posts: 1,334

Re: Prevent Auto-load of table in EG

Posted in reply to ChrisHemedinger

Another place that I've experienced slow initial loading of the view of the table is if the underlying data is a view in a database; although EG (via SAS) is only requesting a small number of records, in the background the database engine has to instantiate the entire view to return those records.

 

Turning off the preview, as Chris suggested, gets rid of this problem as well.

 

Tom

Community Manager
Posts: 3,463

Re: Prevent Auto-load of table in EG

Check (actually uncheck) this option in Tools->Options, Data, Data General:

 

opts.png

 

You might take a little time to explore some other options settings too.  You can eliminate several behaviors that you might find annoying -- not all of the out-of-the-box settings are best for everyone. Here are my recommendations.

Contributor
Posts: 41

Re: Prevent Auto-load of table in EG

Posted in reply to ChrisHemedinger

Thanks so much for pointing me to your blog!  These suggestions are great and will absolutely help!

___________________________________
The fact that I ask for help simply means I am inexperienced and under-educated. Please don't assume I am incompetent and uneducated.
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 474 views
  • 4 likes
  • 4 in conversation