Desktop productivity for business analysts and programmers

Output file name in process flow view doesn't match stipulated name

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 18
Accepted Solution

Output file name in process flow view doesn't match stipulated name

There seems to be a bug in one branch of my process flow (it worked fine before today). When I choose a certain name for my output dataset (say, Work.Controlled_Flag), the output dataset shown in my process flow is still something generic (like Work.QUERY_FOR_ETC_001). But the actual name seems to still exist - when I join tables and such, the names of the datasets in the file explorer is my custom names. It just seems to display wrongly in the process flow view.

Any thoughts to what could be causing this?


Accepted Solutions
Solution
‎05-16-2014 08:19 AM
Community Manager
Posts: 2,707

Re: Output file name in process flow view doesn't match stipulated name

You might try this option in Tools->Options, Project Views - Display full path of referenced data and files

fullpath.png

Chris

View solution in original post


All Replies
Occasional Contributor
Posts: 18

Re: Output file name in process flow view doesn't match stipulated name

Oh, I think I might have an idea of what happened. My process flow view is displaying labels of datasets, but I really want dataset name (and for some reason the name doesn't automatically copy over to the label). So I have to label everything manually in the task, in addition to specifying output dataset name?

Occasional Contributor
Posts: 18

Re: Output file name in process flow view doesn't match stipulated name

My bad, I understand it better now. The labels display in the workflow but the names don't.

Solution
‎05-16-2014 08:19 AM
Community Manager
Posts: 2,707

Re: Output file name in process flow view doesn't match stipulated name

You might try this option in Tools->Options, Project Views - Display full path of referenced data and files

fullpath.png

Chris

Regular Learner
Posts: 1

Re: Output file name in process flow view doesn't match stipulated name

Hello, I am new to this forum but have been using SAS EG for the last 6 years. I found this string and could use some help and/or suggestions. Sometimes when I create a query in SAS EG the Output names I specified within the Query building wizard do not show up under the output icon in the Process Flow, instead the generic “QUERY_FOR…” is displayed. I know that the underlying file name I designated for the output was saved because I can see that when I look at the Properties of the output data. For some reason, the Label information did not get updated however. Additionally this issue does not happen for me all the time. Sometimes I can build a full date query string with several interlinked query subsets and every one of them will have the name I specified displayed in the Process Flow, sometimes none of them will be displayed, and others times it will be a mix of both. I tried the solution that Chris Hemedinger posted on 5/16/2014 but that did not resolve my issue. Any thoughts or suggestion would be greatly appreciated.

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 380 views
  • 0 likes
  • 3 in conversation