Desktop productivity for business analysts and programmers

Not able to unzip or read .gz file

Reply
New Contributor
Posts: 4

Not able to unzip or read .gz file

[ Edited ]

Hi ,

I'm using SAS Enterprise Guide 7.13 (sas 9.4) & I have file in the following format : filename.csv.gz
I've tried using the following command for filename:


1) Filename zipfile ZIP "/home/abc/filename.csv.gz" GZIP;

 

but I'm getting the following error :
ERROR : Error in the FILENAME statement.
ERROR : Invalid option name GZIP.

2) Filename zipfile PIPE "/home/abc/filename.csv.gz" ;

 

but I'm getting the following error :
ERROR : Insufficient authorization to access PIPE.
ERROR : Error in the FILENAME statement.


File contains csv file & I'm not able to unzip or read that file.

Please let me know how to read/unzip & after unzipping, again how to zip in .gz format .
Thanks in advance,
Ajit

Community Manager
Posts: 3,462

Re: Not able to unzip or read .gz file

Posted in reply to ajitsingh1

The GZIP feature was added to FILENAME ZIP in SAS 9.4 Maint 5.  What version do you have? Run:

 

proc product_status; run;

To find out.

New Contributor
Posts: 4

Re: Not able to unzip or read .gz file

Posted in reply to ChrisHemedinger
I'm having 9.4 Maint 3.
SAS Employee
Posts: 315

Re: Not able to unzip or read .gz file

Posted in reply to ajitsingh1

Also, check if you have access to run OS commands (XCMD).

 

Run...

 

proc options;

run;

 

and check if you have XCMD or NOXCMD set.

New Contributor
Posts: 4

Re: Not able to unzip or read .gz file

NOXCMD : Disables the X command in SAS.
SAS Employee
Posts: 315

Re: Not able to unzip or read .gz file

Posted in reply to ajitsingh1

On which OS is SAS 9.4 installed ?

New Contributor
Posts: 4

Re: Not able to unzip or read .gz file

It is on Windows
SAS Employee
Posts: 315

Re: Not able to unzip or read .gz file

Posted in reply to ajitsingh1

ok, see my reply....

SAS Employee
Posts: 315

Re: Not able to unzip or read .gz file

Posted in reply to ajitsingh1

For Windows, set -xcmd option in your sasv9.cfg file and restart your SAS Enterprise Guide session. Check that the setting has taken effect by running proc options first.

 

http://support.sas.com/documentation/cdl/en/hostwin/69955/HTML/default/viewer.htm#p0xtd57b40ehdfn1jy...

 

 

Ask a Question
Discussion stats
  • 8 replies
  • 902 views
  • 0 likes
  • 3 in conversation