Desktop productivity for business analysts and programmers

Not able to access SASApp in SAS EG 6.1

Reply
Frequent Contributor
Posts: 90

Not able to access SASApp in SAS EG 6.1

Hi All,

 

My Customer SAS Site been configured with 3 tier architecture and it was working fine till last week.

 

since Monday on words, the SAS Users are not able to accee/expand SASApp(Under Servers) in EG to access libraries and Files Folders.

 

The SAS Server VM are running on physical OVM Comupte nodes for high availablity  and over the week end the Unix team upgraded kernel in OVM Compute nodes but they have not changed any of the configuration files in SAS Severs related.

 

No Error on EG and No errors on Objectspawner log files as well. i am able to validate all server in SAS SMC using end user account.

 

Can anyone suggest why its happend like this and how to get back to users to access SSApp in EG?

 

Thanks,

Ram

 

 

 

 

Super User
Posts: 3,233

Re: Not able to access SASApp in SAS EG 6.1

I suggest a restart of the SAS Compute server would be a good start since there were server changes made.

 

I'm assuming that EG can connect OK to SASApp? What version of SAS is this?

 

I'd also check out the SASApp workspace logs to see if anything is reported.

Frequent Contributor
Posts: 90

Re: Not able to access SASApp in SAS EG 6.1

Hi SASWiki,

 

I have already did taht restarting the SAS Compute servers and it is SAS 9.4 M2 version.

 

Yes, user or me can connect to SAS Metadata server, but when i expand the Servers > SASApp(not working) taking time forever without error either on EG screen or in ObjectSpwner Log files andMetadata server log files.

 

 

 

Thanks,

Chenchu.

Trusted Advisor
Posts: 1,174

Re: Not able to access SASApp in SAS EG 6.1

Hi @Ram4sas,

 

I would propose you to follow the steps:

 

- Validate your Workspace server in a SAS Management Console from your servers. Probably it can validate. If not, your ObjectSpawner or OWrkspace server have an internal problem (service not started, configuration issue, firewall...)

- If you can validate on this way, try to validate from a SMC on your client and try to run a "telnet yourcomputehost yourworkspaceserver port". If you can connect and validate, maybe EG has an issue. If you cannot, then there was a change on the firewall rules and something is blocking the access from your EG clients to the server's workspace server (SASApp)

 

I would gues that most probably the issue is the las one... but go figure. Good luck with the tests and solutions! Please let us know how it goesSmiley Happy

 

Regards,

Juan

Frequent Contributor
Posts: 90

Re: Not able to access SASApp in SAS EG 6.1

Hi Juan,

 

I am able to validate the workspace servers from SMC Client and SMC from Server as well.

I am able to do telnet/connect to SAS Compute server on 8591 port and performed integration Technologies Configuration test to Workspace server on 8591 port....it was successfull.

 

There is no doubt on SAS EG as i am able to access Prod Server and expand/Access SASApp succefully.

 

its not giving any error...either at EG end and in Log files too.

 

 

Thank you,

Ram

Super User
Posts: 3,233

Re: Not able to access SASApp in SAS EG 6.1

[ Edited ]

So does this mean you have two SAS Compute servers, one being Prod which works OK with EG and the other which doesn't?

Frequent Contributor
Posts: 90

Re: Not able to access SASApp in SAS EG 6.1

Hi SASWiki,

 

I mean we have 2 SAS Environments called Prod and Test with completed separate machines.

 

Users can connect to SAS Prod environment and run the programes successfully, but not to SAS Test Environemnt.

 

I can Launch workspace server using user account in Putty session, tested telnet test to compute server machine name on 8591 port, tested integration technologies test to workspaveserver on 8591 port. everything working fine exept unable to access Server > SASApp in EG.

 

Thanks,

Ram

Trusted Advisor
Posts: 1,174

Re: Not able to access SASApp in SAS EG 6.1

Hi,

 

Any chance that the EG Client is installed under a virtualization software? Citrix, AppV or ThinApp are good examples.

 

Either way, I would suggest you to enable the logging facility in EG, close EG, start it again them try to connect to both SASApps. The log should provide more info.

 

Thanks in advance,

Regards,

Juan

Frequent Contributor
Posts: 90

Re: Not able to access SASApp in SAS EG 6.1

I am able to connecto SAS Prod SAS Servers environment, no issues on that- so no changed made in OS level.

 

The issue is only to connect SAS Test environment, not able to access/exoand SASApp in EG, but i can connect to SAS Metadata Server.

 

Thanks,
Ram

Trusted Advisor
Posts: 1,174

Re: Not able to access SASApp in SAS EG 6.1

Hi @Ram4sas,

 

could you give a look on any of the questions/tips mentioned before?

 

Summarizing:

- Are the clients running as virtual clients (AppV, Citrix, etc)?

- Did you enabled the logging on EG clients?

 

Additionally, you could enable logging on the workspace server (carefull, since this can create a lot of big log files):

http://support.sas.com/documentation/cdl/en/bisag/64088/HTML/default/viewer.htm#a003285844.htm

 

 

Frequent Contributor
Posts: 90

Re: Not able to access SASApp in SAS EG 6.1

Hi,

 

Tha clients are in Windows machine and can connect to SAS Prod Environment successfully. the Issue to connect TEST SAS Environment.

 

I have enabled Log for EG and Workspace server and attached as well for your reference.

Attachment
Ask a Question
Discussion stats
  • 10 replies
  • 673 views
  • 0 likes
  • 3 in conversation