Desktop productivity for business analysts and programmers

MEMSIZE no admin rights

Accepted Solution Solved
Reply
Occasional Contributor jo1
Occasional Contributor
Posts: 14
Accepted Solution

MEMSIZE no admin rights

Hi,

 

I am using SAS Enterprise Guide 7.1 and would like to change the MEMSIZE and have found ways to do this but have been coming up with the following issues. 

 

1.  I do not have admin rights on my computer so cannot change the config file where it currently is placed.

 

2.  I cannot work out how to change the location of the config file on start up so that I can save the config file in a location where I do have rights to change it.

 

3. I was able to put -MEMSIZE 0 after the exe file in the Target of the start up icon for SAS 9.4 but this doesn't work for EG,

 

TARGET: "C:\Program Files\SASHome\SASEnterpriseGuide\7.1\SEGuide.exe" -MEMSIZE 0

 

4. Although some of the things in the config file can be change in code it doesn't appear that MEMSIZE is one that you can

 

If anyone has a way around this issues it would be greatly appreciated.

 

Jo


Accepted Solutions
Solution
‎06-14-2017 06:16 PM
Super User
Posts: 5,388

Re: MEMSIZE no admin rights

A similar approach to @KurtBremser is if you get temporary admin rights, edit the existing config file, to point to another config file in a place were you have write access.

In this way, you can always change your SAS startup options without being admin.

Data never sleeps

View solution in original post


All Replies
Occasional Contributor jo1
Occasional Contributor
Posts: 14

MEMSIZE no admin rights

Hi,

 

I am using SAS Enterprise Guide 7.1 and want to change the MEMSIZE.  I've found a few ways to do this but am coming up with problems to them - I'm hoping someone else has gotten around the issues I have:

 

1.  I do not have admin rights over my computer so can not change the config file

 

2.  I can't work out how to get SAS on start up to point to a different location for the config file (that way I could save it in a location where I can make changes).

 

3. I have tried putting -MEMSIZE 0 in the Target after the exe file on the start up icon, this appears to work for SAS 9.4 but doesn't seem to work the same way for EG

 

4. It seems that although I can change some things in the config file by code the MEMSIZE is not one of them

 

Any help would be appreciated.

 

 

Super User
Posts: 19,167

Re: MEMSIZE no admin rights

Do you know if EG is running on the server or if it's installed locally on your machine?

If it's on the server, it's a server setting and you'll need your SAS administrator to change it Smiley Sad

Occasional Contributor jo1
Occasional Contributor
Posts: 14

Re: MEMSIZE no admin rights

Sorry should have said.  It's just a single licence running on a local machine.

 

Thanks

Super User
Posts: 3,237

Re: MEMSIZE no admin rights

While it is common for organisations to remove admin rights to PC users by default there is usually a way for your IT department to either make the required change for you or to give you temporary admin rights so you can make the change yourself. Do you have an IT Help Desk to discuss this with? 

Occasional Contributor jo1
Occasional Contributor
Posts: 14

Re: MEMSIZE no admin rights

"Help" being the important word here lol - yep I have a call in and we have made a once off change for the moment.  I do want to be able to test the different values etc and was hoping to reduce the wait times.  Getting admin rights (although this is near to impossible) and/or logging a call each time I want/need to make a change are both solutions but I was trying to see if I could bypass that process.

 

Thanks

Super User
Posts: 7,446

Re: MEMSIZE no admin rights

Since MEMSIZE only affects the workspace server (SAS) process, but not EG itself, you can test the effect of different MEMSIZEs in Base SAS.

- copy the file sasv9.cfg from C:\Program Files\SAS\SASFoundation\9.4 to your desktop

- create a link to SAS on your desktop; the target should be "C:\Program Files\SAS\SASFoundation\9.4\sas.exe" -config "C:\Users\Username\Desktop\sasv9.cfg"

- now you can manipulate the -memsize in sasv9.cfg and run your codes in display manager.

 

Some path names might be different on your system, so use them as a guideline; the core of my post is the fact that you can create individualized config files in your own directory tree, and use them. Make sure that other directives in the cfg can work (like the WORK location and so on).

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Solution
‎06-14-2017 06:16 PM
Super User
Posts: 5,388

Re: MEMSIZE no admin rights

A similar approach to @KurtBremser is if you get temporary admin rights, edit the existing config file, to point to another config file in a place were you have write access.

In this way, you can always change your SAS startup options without being admin.

Data never sleeps
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 226 views
  • 1 like
  • 5 in conversation