Desktop productivity for business analysts and programmers

Is SAS EG 7.1 compatible with SQL 2016?

Accepted Solution Solved
Reply
New Contributor
Posts: 2
Accepted Solution

Is SAS EG 7.1 compatible with SQL 2016?

[ Edited ]

My company is working on upgrading all our database servers from SQL 2007 to SQL Server 2016. All the ports and servers will have the same name, but I want to make sure that SAS EG 7.1 is compatible with SQL 2016. I cannot find any documentation on SAS SQL compatibility. So I was wondering if anyone can help me with this. Thanks!


Accepted Solutions
Solution
Wednesday
SAS Employee
Posts: 6

Re: Is SAS EG 7.1 compatible with SQL 2016?

Enterprise Guide is a client application that must connect to a SAS server in order to work. It does not do any processing on its own. It generates SAS code, sends it down to the server for processing, and waits for the results. So the better question is whether or not the version of SAS you have installed on the server is compatible with SQL server 2016 (I'm assuming by 'SQL 2016' you meant SQL Server 2016').

In order for SAS to connect to a database such as SQL Server, there has to be a SAS/Access product licensed and installed on the SAS server, such as SAS/Access to ODBC or SAS/Access to OLEDB. These SAS/Access products can be used to connect to any ODBC or OLEDB-compliant database, as long as the database vendor can supply the appropriate drivers. So in a nutshell, as long as Microsoft can provide the appropriate ODBC driver or OLEDB provider (depending on the SAS/Access product you have licensed) for SQL Server 2016, it will work fine with SAS.

View solution in original post


All Replies
Super User
Super User
Posts: 9,402

Re: Is SAS EG 7.1 compatible with SQL 2016?

SQL is a programming language not an application.  Please supply what database you are talking about, e.g. SQLServer, MySQL etc.

New Contributor
Posts: 2

Re: Is SAS EG 7.1 compatible with SQL 2016?

Thanks for your response. The database is being moved to SQLServer 2016. Is there any documentation that supports that SAS EG 7.1 is compatible with it?

SAS Employee
Posts: 296

Re: Is SAS EG 7.1 compatible with SQL 2016?

@itareque

 

1.) Which version of SAS are you using ? 9.4 ?

2.) Are you using SAS Access to MS-SQL Server, SAS Access to ODBC or another method as described by @ChrisHemedinger ?

3.) Do you connect to a SAS server ? If so, which OS ? Linux or Windows ?

 

Valued Guide
Posts: 558

Re: Is SAS EG 7.1 compatible with SQL 2016?

"Compatible" may not be the right word to use. Yes, SAS can connect even after the upgrades. You might use the right drivers to connect from SAS after the upgrade. 

Thanks,
Suryakiran
Solution
Wednesday
SAS Employee
Posts: 6

Re: Is SAS EG 7.1 compatible with SQL 2016?

Enterprise Guide is a client application that must connect to a SAS server in order to work. It does not do any processing on its own. It generates SAS code, sends it down to the server for processing, and waits for the results. So the better question is whether or not the version of SAS you have installed on the server is compatible with SQL server 2016 (I'm assuming by 'SQL 2016' you meant SQL Server 2016').

In order for SAS to connect to a database such as SQL Server, there has to be a SAS/Access product licensed and installed on the SAS server, such as SAS/Access to ODBC or SAS/Access to OLEDB. These SAS/Access products can be used to connect to any ODBC or OLEDB-compliant database, as long as the database vendor can supply the appropriate drivers. So in a nutshell, as long as Microsoft can provide the appropriate ODBC driver or OLEDB provider (depending on the SAS/Access product you have licensed) for SQL Server 2016, it will work fine with SAS.

SAS Employee
Posts: 296

Re: Is SAS EG 7.1 compatible with SQL 2016?

@itareque

 

Below are the system requirements for SAS 9.4. Select the OS on which your SAS deployment runs e.g. Linux and then look at the requirements for the particular SAS/Access engine you are using e.g. SAS/Access to MS-SQL Server

 

When in doubt, always contact SAS Technical Support

 

https://support.sas.com/en/search.html?q=*%3A*&fq=siteArea%3A%22System%20Requirements%22&fq=releases...

Community Manager
Posts: 3,378

Re: Is SAS EG 7.1 compatible with SQL 2016?

In addition to the SAS/ACCESS methods, there are two other methods that people use to connect EG to Microsoft SQL Server:

  • File->Open->OLE DB... -- connects directly to a database.  Pulls data through EG to SAS for analysis.  As such, it can be nonperformant for large data -- but sometimes folks use this anyway.
  • File->Open->OLAP Cube, Private OLAP Servers -- connects to a Microsoft Analysis Services source using OLE DB for OLAP.

In either case, Microsoft SQL Server 2016 should work fine.  The magic is in the OLE DB provider, as others have said.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 170 views
  • 2 likes
  • 6 in conversation