Desktop productivity for business analysts and programmers

Information Maps in SAS EG

Occasional Contributor
Posts: 12

Information Maps in SAS EG

When I import an Information Map (without any filter) in SAS EG it keeps running forever and never gets done..............Why is that ...............
Community Manager
Posts: 3,344

Re: Information Maps in SAS EG

This sounds like a question for SAS technical support - it might be specific to your information map.

Is the data in the map very large?

Is the data defined in terms of the SAS server you are using to access it? That is, can your SAS session access it directly or must it connect to another, remote session?

These questions can be tricky to answer unless you are very familiar with how the information map is defined.

SAS Enterprise Guide generates a SAS program to read data from the map, using the information maps library engine (INFOMAPS, or sasioime in the code you see). Can you run that code successfully?

Posts: 51

Issues with proc mixed

Posted in reply to ChrisHemedinger



I am trying to run a proc mixed analysis for the following data:


ID            Score        year         group        othervariables

1                80             0              1

1                90             1              1

1                77             2              1

2                66             0              0

2                90             3              0

2                82             6              0

.                  .

.                  .

.                  .


So the years with scores are from 0 to 7 but some have scores years 0, 1,2, 3, 6 and some 0, 3, 6 etc. It varies. The dataset is fairly large and includes 17155 observations and 223 variables...I need to adjust for some variables in the model (around 7 etc).


When running the unadjusted model using the following code:

proc mixed data=cup.cup;

class year group;

model F393MSE = group year group*year;

repeated year/ subject=id type=ar(1);



I get the following error:

WARNING: ODS graphics with more than 5000 points have been suppressed. Use the PLOTS(MAXPOINTS= )

option in the PROC MIXED statement to change or override the cutoff.

WARNING: Stopped because of infinite likelihood.


I added the  PLOTS(MAXPOINTS= NONE) in the statement, but it didn't work.

Surprisingly, when I added covariates in the model (around seven) the model runs. However, I do need to run the unadjusted.


Also, one other question. How does one run a GLM with REML method and specify the random effects...


Thank you for your help!

Ask a Question
Discussion stats
  • 2 replies
  • 3 in conversation