Desktop productivity for business analysts and programmers

Import Error: System.Runtime.InteropServices.COMException

Reply
N/A
Posts: 0

Import Error: System.Runtime.InteropServices.COMException

I am trying to import an old EG 2.0 project into EG 4.1 and I am getting this error. Any ideas?

Thanks,

Robert


Enterprise Guide has encountered an unexpected error; click Show Details for more information.

--------------------------------------------------------

System.Runtime.InteropServices.COMException

COM object with CLSID {62B2A66D-182A-412F-8D54-B8C9B203C66A} is either not valid or not registered.

------------------------------ Technical Information Follows ------------------------------

[SAS.EG.ProjectElements]

COM object with CLSID {62B2A66D-182A-412F-8D54-B8C9B203C66A} is either not valid or not registered.

----------------------------------------------------

at SAS.EG.ProjectElements.Migrator.Convert(OpenName FileToConvert, OpenName newFileName)
at SAS.EG.SEGuide.MainForm.MigrateOldProject(OpenName openName)
at SAS.EG.SEGuide.MainForm.OpenExistingProject(OpenName openName)
at SAS.EG.SEGuide.Util.AddExistingItem(OpenName on, OpenAs openFileAs, Boolean bAutoOpen)
at SAS.EG.SEGuide.MainForm.AddExistingLocalItem(OpenName on)
at SAS.EG.SEGuide.MainForm.CheckForFilesToOpen()
at SAS.EG.SEGuide.MainForm.OnAppLoaded()System.Runtime.InteropServices.COMException

COM object with CLSID {62B2A66D-182A-412F-8D54-B8C9B203C66A} is either not valid or not registered.

------------------------------ End of Technical Information ------------------------------
N/A
Posts: 0

Re: Import Error: System.Runtime.InteropServices.COMException

No ideas yet hey? I really need to open the old project. With that Idea, I do have EG 2.0, can EG 2.0 and 4.1 co-exist? That is I can install the old EG so I can open and run the old project until a hotfix or something can solve my issues.

Thanks,

Robert
Community Manager
Posts: 2,889

Re: Import Error: System.Runtime.InteropServices.COMException

Robert,

Yes, EG 2.0 and 4.1 can coexist.

The error you see looks like an incomplete installation. You might be able to repair it by:

1. Open a command prompt at your EG 4.1 installation directory.

2. Run "seguide /register"

Chris
Ask a Question
Discussion stats
  • 2 replies
  • 178 views
  • 0 likes
  • 2 in conversation