Desktop productivity for business analysts and programmers

How to increase the memsize in SAS EG?

Accepted Solution Solved
Reply
New Contributor
Posts: 3
Accepted Solution

How to increase the memsize in SAS EG?

Hi everyone!

 

I would like to increase the memsize setting (from 2G to 8G) because my program stops and sends me the error message 'out of memory'. I'm aware of the solution provided here: http://support.sas.com/kb/40/480.html. But I don't understand how I can do it.

If the information can help, I'm using SAS EG in my local machine.

 

Thanks for your answers.


Accepted Solutions
Solution
‎01-20-2017 09:19 AM
Esteemed Advisor
Posts: 6,669

Re: How to increase the memsize in SAS EG?

OK, the only step I see that might cause it is the proc univariate, but with only one variable and 500k observations that should not pose a problem. But i will leave that to others who are more familiar with it.

Can you infer from the log which if the steps causes the memory overflow?

 

Since you have a local SAS (and no metadata infrastructure), setting the memsize in the main sasv9.cfg located in the Program Files\SAS\SASFoundation\9.4 directory should work.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers

View solution in original post


All Replies
Esteemed Advisor
Posts: 6,669

Re: How to increase the memsize in SAS EG?

With a memsize of 2G, your problem might come from a mistaken way to use a procedure or data step.

Please post your code.

 

Setting the memsize must occur when a SAS process starts, from the configuration file or the commandline.

Which server do you use in EG? "Local" or another?

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
New Contributor
Posts: 3

Re: How to increase the memsize in SAS EG?

Thanks Kurt for your answer.

 

Please find appended the code.

Briefly, it aims to estimate a risk associated with a bootstrapped 95%CI (500 replicates) for about a thousand of drug/event pairs. The calculations are based on a population table of 500k persons.

 

I use the server 'local' in SAS EG.

Attachment
Solution
‎01-20-2017 09:19 AM
Esteemed Advisor
Posts: 6,669

Re: How to increase the memsize in SAS EG?

OK, the only step I see that might cause it is the proc univariate, but with only one variable and 500k observations that should not pose a problem. But i will leave that to others who are more familiar with it.

Can you infer from the log which if the steps causes the memory overflow?

 

Since you have a local SAS (and no metadata infrastructure), setting the memsize in the main sasv9.cfg located in the Program Files\SAS\SASFoundation\9.4 directory should work.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
New Contributor
Posts: 3

Re: How to increase the memsize in SAS EG?

Thanks a lot Kurt! I achieved to increase the memsize thanks to your advice.

 

The log does not indicate any helpful information about the causes of the memory overflow...

As you, I assume that the problem comes from the bootstrap process, but I don't know which point exactly.

 

Esteemed Advisor
Posts: 6,669

Re: How to increase the memsize in SAS EG?

The best advice I can give is to extract the code from the macro, set the macro variables manually and let the steps run one by one.

It's best to do the "macro-izing" of code after the steps work on their own.

Also add %put statements in the macro to help identify which macro iteration (if you have such) leads to the crash, if you can't test it manually owing to too many iterations.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 783 views
  • 0 likes
  • 2 in conversation