Desktop productivity for business analysts and programmers

How to disable Computed Column / Advanced Filter Builder Secondary Panes

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 12
Accepted Solution

How to disable Computed Column / Advanced Filter Builder Secondary Panes

I'm sure this is an option that just needs to be turned off but I can't locate where the option is at. On my old machine and on my co-workers' installs of SAS EG this has never appeared so I'm not sure how it was turned on in the first place. When I go into the Computed Column builder or the Advanced Filter builder, there is a gray secondary pane that appears below the text box where you enter your code. The pane reproduces what is entered in the text box but encloses some column names in quotes. I'd like to disable this second pane as it takes up screen space that I'd rather have for code and I have to drag it down out of view every time I enter one of the builder windows.

 

I'm running SAS Enterprise Guide Version 5.1 (5.100.0.13304) Hot fix 17 (32-bit) on Windows 7

 

Thanks!

 

SAS EG Second Pane.png


Accepted Solutions
Solution
‎05-24-2016 08:52 AM
SAS Super FREQ
Posts: 272

Re: How to disable Computed Column / Advanced Filter Builder Secondary Panes

The first (editable) text pane is where you type the advanced expression, which requires you to use column names (can't use column labels) to reference variables.  That secondary read-only text pane is the "show column labels" version of the advanced expression.  The only difference is that it shows column labels (if present), rather than column names.  As such, it is the more human-readable version, depending on the column names and labels (if used).

 

The secondary pane only appears if the "Use labels for column names" option in EG's Tools->Options->Data->Data General tab is checked.  So, you can hide it by unchecking that option.  (It would have been nicer to have a way to hide that secondary pane right in the dialog.)

 

screenshot.png

View solution in original post


All Replies
Trusted Advisor
Posts: 1,059

Re: How to disable Computed Column / Advanced Filter Builder Secondary Panes

That's weird!

 

I'm running 6.1, and no matter what I do, I can't get that second screen to appear.

 

Mystified,

  Tom

Solution
‎05-24-2016 08:52 AM
SAS Super FREQ
Posts: 272

Re: How to disable Computed Column / Advanced Filter Builder Secondary Panes

The first (editable) text pane is where you type the advanced expression, which requires you to use column names (can't use column labels) to reference variables.  That secondary read-only text pane is the "show column labels" version of the advanced expression.  The only difference is that it shows column labels (if present), rather than column names.  As such, it is the more human-readable version, depending on the column names and labels (if used).

 

The secondary pane only appears if the "Use labels for column names" option in EG's Tools->Options->Data->Data General tab is checked.  So, you can hide it by unchecking that option.  (It would have been nicer to have a way to hide that secondary pane right in the dialog.)

 

screenshot.png

Occasional Contributor
Posts: 12

Re: How to disable Computed Column / Advanced Filter Builder Secondary Panes

Thank you! Thank you! Thank you! It's so nice to open up the builder and see that nice big test pane.

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 299 views
  • 1 like
  • 3 in conversation