Desktop productivity for business analysts and programmers

How to avoid an epg jungle?

Reply
Occasional Contributor
Posts: 19

How to avoid an epg jungle?


I have a structured suite of sas codelet in my EPG work flow. Each of them consists of many data steps and proc sqls. The execution of each of these steps gives me all the results up to 50 tables for each codelet.  I would like sas to calculate the tables without showing the calculated tables. Is that possible? Maybe a trivial option? Wasn't able to google any solution.

Thanks

Gregor

Attachment
Attachment
Occasional Contributor
Posts: 15

Re: How to avoid an epg jungle?

Hey Gregor,

I have the same issue and find it very irritating.  I've found three ways to deal with the jungle.  They all have their pluses and minuses.

1) In EG 5.1, if you go to File->Project Properties->Output Data Sets and change the Maximum Number of output data sets to 0 then EG will not show them after the run.  You can also change this setting by going to Tools->Options->Results General.  Unfortunately, EG will still put a note after the codelet runs that "indicates that the data set limit was reached and specifies the total number of output data sets that were created".  Better than the jungle, but still annoying.

2) Use PROC DATASETS; Delete; to delete any datasets that you do not need after the code has run.

3) Clear the library name in which the datasets are stored as mentioned here: http://stackoverflow.com/questions/10979058/how-can-i-stop-tables-appearing-in-enterprise-guide

I hope this helps!

Jonathan

Contributor
Posts: 32

Re: How to avoid an epg jungle?

Hey Gregor


Have you tried the 'NO PRINT' option?

Cheers

Fred

Occasional Contributor
Posts: 19

Re: How to avoid an epg jungle?

Hi Fred,

thanks, but how is the syntax in order to achieve the change?

SAS accepts the statements to be like that

proc sql noprint;

create table lib.file as

.....

but the created tables are still in the output.

Best,

Gregor


Contributor
Posts: 32

Re: How to avoid an epg jungle?

Sorry Gregor I was a bit quick off the mark there.

Cannot get this to work for neither DATA or PROC SQL the way I thought it would..

Ask a Question
Discussion stats
  • 4 replies
  • 426 views
  • 4 likes
  • 3 in conversation