Desktop productivity for business analysts and programmers

How to add effects on post hoc least squares dialogue box?

Reply
N/A
Posts: 0

How to add effects on post hoc least squares dialogue box?

I'm stuck on linear models in EG. I've assigned task roles and set up my two-way ANCOVA model. I get to the post hoc least squares and clicked on add an effect. Then a line appears in the effects to estimate dialogue box and says . I've tried double and right clicking the line; also tried to double click or drag and drop my class effects (which do appear in the options for means tests dialogue box to the right). But no matter what I've tried, nothing goes into the effects to estimate.

HELP! How do I get this to work?

Thanks! Cheryl@UVA
Community Manager
Posts: 2,697

Re: How to add effects on post hoc least squares dialogue box?

In order to define least squares effects, you must:

1. On the Task Roles page, assign at least one variable to the Classification role
2. On the Model page, add the classification variable as an Effect.
3. On the Post Hoc Tests->Least Squares page, click Add -- it will add the classification variable as the selected effect. If you have more than one classification variable assigned as an effect, then you can select among them.

Hint: the task window does show some helpful messages in the status bar, providing cues as to what is required to use the controls on this page.

Chris
N/A
Posts: 0

Re: How to add effects on post hoc least squares dialogue box?

I must be dense! I have done the following:
1. on task roles page - assigned variables to dependent, quantification, and classification
2. on model page -- added covariate, main effects (classification variables specified as such on task role page), and interaction between main effects
3. on post hoc tests > Least squares page, clicked add. In the middle dialogue box that is titled "Effects to estimate" it still says I can see the effects in the dialogue box to the right under "Options for means tests" but there is no way that I can figure out to get the effects into the middle dialogue box. Consequently the run button is still grayed out.

What step (probably very easy!) am I still missing?

Thanks!

Cheryl@UVA
Ask a Question
Discussion stats
  • 2 replies
  • 101 views
  • 0 likes
  • 2 in conversation