Desktop productivity for business analysts and programmers

Format created, but doesn't show up in list of available formats

Reply
N/A
Posts: 0

Format created, but doesn't show up in list of available formats

I created a format to provide labels for a variable that is stored numerically. However, when I try to associate the format with the variable it is not on the list of formats I can choose from. I feel like I must be missing some simple step here, but I can't figure out what it is. I've followed the instructions in the Little SAS Book for EG, checked the code, have made sure the format is not stored in a temporary drive, etc. As far as I can tell, it looks like it should work, but isn't, and I'm getting no indications why. Any suggestions?
Thanks.
Community Manager
Posts: 2,891

Re: Format created, but doesn't show up in list of available formats

I have a couple of suggestions.

First, make sure the format is located in a library that is in your format search path (FMTSEARCH option). By default in EG, this is something like (WORK EGTASK SASUSER LIBRARY). You can check PROC OPTIONS OPTION=FMTSEARCH; to see what the current setting is for you.

Next, EG maintains a cached list of formats that it gathers from the SAS server. To make sure that your new format has a chance to be detected, go to Tools->Options->Data: Data General, and look at the "SAS Formats/Informats Cache". If the button is enabled, click "Clear cache". It will be enabled only if you have already used EG to browse the list of available formats during the current EG session.

Chris
Occasional Contributor
Posts: 16

Re: Format created, but doesn't show up in list of available formats

Handiest to save your formats in a library that EGuide is searching, as per previous post. However, if like me, you need to store the formats in a library other than sasuser, work or egtask (the ones EGuide seems to search by default) you can point EGuide towards your library. In Tools - Enterprise Guide Explorer go to your server (or "local" I guess if its standalone setup) and put in the start-up command in the properties to point towards the library perm --

options fmtsearch = (perm work sasuser egtask)

I had to apply the latest EGuide Hotfix to allow me to enter the start-up command without error. Worked fine then.
Ask a Question
Discussion stats
  • 2 replies
  • 117 views
  • 0 likes
  • 3 in conversation