Desktop productivity for business analysts and programmers

Font size is huge in enhanced editor

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

Font size is huge in enhanced editor

Hi: I just installed Enterprise Guide on a new computer. The font size is huge in the program editor and the slide bars to move vertically and horizontally are huge too. 

 

I tried clicking in a program and then Program, Editor Options, Appearance, and setting the text to Size = 8. But the text is still too big.

 

Thanks a million for any advice!!!!!!!!!!!!!

 

program editor.PNG

enhanced editor options.PNG


Accepted Solutions
Solution
‎08-15-2016 04:08 PM
Community Manager
Posts: 2,953

Re: Font size is huge in enhanced editor

Do you have a custom DPI setting for your Windows system?

 

Right-click on desktop, select Screen Resolution.  In the Display settings, look at the "Set custom text size (DPI)" option.

 

dpi.png

 

Try to toggle the "Windows XP style DPI scaling" and see if that helps.

View solution in original post


All Replies
Super User
Posts: 11,343

Re: Font size is huge in enhanced editor

I would recommend looking at the editor scheme drop down list and pick one. The approach you used would only effect one type of text, the comments.

 

Also, if you changed the screen resolution to something a bit coarser than when SAS was installed you could get this appearance issue.

New Contributor
Posts: 4

Re: Font size is huge in enhanced editor

Thank you for your suggestion! I created a new editor scheme and altered all the file elements (comments, etc.). Unfortunately, that did not work. And I am using the same screen resolution as when I installed.

Super User
Posts: 3,252

Re: Font size is huge in enhanced editor

Is this EG 7.12 by any chance with the zoom capability? Have you tried "unzooming"?

New Contributor
Posts: 4

Re: Font size is huge in enhanced editor

No, I am using 6.1.

Solution
‎08-15-2016 04:08 PM
Community Manager
Posts: 2,953

Re: Font size is huge in enhanced editor

Do you have a custom DPI setting for your Windows system?

 

Right-click on desktop, select Screen Resolution.  In the Display settings, look at the "Set custom text size (DPI)" option.

 

dpi.png

 

Try to toggle the "Windows XP style DPI scaling" and see if that helps.

New Contributor
Posts: 4

Re: Font size is huge in enhanced editor

Posted in reply to ChrisHemedinger

Thanks a million for the suggestion! Yes, that is probably as close to a solution as I can find. Unfortunately, when I get the size of SAS to display in a normal manner on an external monitor, it makes the size of programs on my laptop screen really small. I appreciate the help!!

Frequent Contributor
Posts: 125

Re: Font size is huge in enhanced editor

Just leaving this here, in case anyone will run into the same trouble like I did randomly this morning:

 

Should you have this problem, although you are not using a custom DPI, then by any means go the ususal Microsoft way...

Do enter a custom DPI setting, log out, log in and then remove the custom DPI setting again, log out, log in.

And you should be good to go.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 4244 views
  • 2 likes
  • 5 in conversation