Desktop productivity for business analysts and programmers

Failure to connect to SAS Metadata server from EG

Accepted Solution Solved
Reply
New Contributor
Posts: 3
Accepted Solution

Failure to connect to SAS Metadata server from EG

I tried to connect to a SAS metadata server from my local PC using EG 4.3 and did not succeed . The log that was generated is the following:

 

A connection could not be made to the SAS Metadata Server but is required for the current operation. Please see your administrator.

--------------------------------------------------------

Connection failed

------------------------------ Technical Information Follows ------------------------------

SAS.EG.SDS.Metadata.MetadataException: Connection failed ---> System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
at SASObjectManager.ObjectFactoryMulti2Class.CreateObjectByServer(String Name, Boolean synchronous, ServerDef pIServerDef, String LoginName, String Password)
at SAS.EG.SDS.Metadata.OMSProvider.Connect()
--- End of inner exception stack trace ---
at SAS.EG.SDS.Metadata.OMSProvider.Connect()
at SAS.EG.SDS.Metadata.MetadataManagerV2.SAS.EG.SDS.Metadata.IMetadataConfiguration.set_ActiveProvider(Provider value)
at SAS.EG.SDS.Dialogs.ProviderConnectDlg.Connect(Object sender, DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

------------------------------ End of Technical Information ------------------------------

 

I tried to solve the issue (or at least get some more information) following general solutions I found on this forum:

 

1 -  I tried to ping the server and was successful;

2 - I tried connecting to the metadata server through SAS Integration Technologies Configuration Wizard using the same credentials I used in SAS EG and succeeded;

3 - I tried connecting to the SAS metadata server from another local machine (in the same network) using the same credentials and succeeded;

4 - IT tried to fix the problem by reinstalling SAS EG on my desktop. This solved the issue for 3 hours and then went back to presenting this problem. IT has no idea about what to do.

 

Therefore I assume it is some problem with my local desktop. Has anyone an idea about this issue? Please help!


Accepted Solutions
Solution
‎04-12-2018 05:22 PM
New Contributor
Posts: 3

Re: Failure to connect to SAS Metadata server from EG

After contacting IT I discovered that the first guy didn't reinstall the SAS EG completly. So after reinstalling it the right way it worked... Sorry for this boring solution. Thanks for your attention guys!

 

PS.: reinstalling the .NET framework had no effect at all.

View solution in original post


All Replies
Respected Advisor
Posts: 4,566

Re: Failure to connect to SAS Metadata server from EG

@jonakie

4 - IT tried to fix the problem by reinstalling SAS EG on my desktop. This solved the issue for 3 hours and then went back to presenting this problem. IT has no idea about what to do.

 

You've done already quite a bit more investigation than what the average user would have done. Point 4) pretty clearly proves that this is an issue with your client side installation. Sooo... it worked for 3 hours and then got pear shape again. And the error log tells you:

System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

 

If you restart your desktop does EG work again? Or does the issue remain? Doing a bit of research one recommendation I found was to re-install the .net framework. Not sure if that would help of course but worth a try. It still doesn't explain why things only stop working after 3 hours - which makes me think "memory leak" or "virus scanner changing stuff".

 

It might be worth to give the .net re-install a try. Else I'd say that's a case where your site's SAS admin should contact SAS Tech Support.

New Contributor
Posts: 3

Re: Failure to connect to SAS Metadata server from EG

If you restart your desktop does EG work again? Or does the issue remain?

Yes... The issue remains. I will test reinstalling the .NET framework and come with more details.
SAS Employee
Posts: 199

Re: Failure to connect to SAS Metadata server from EG

Hi @jonakie,

 

It's a strange behavior.

Between the time you reinstalled SAS Enterprise Guide (EG) and the problem coming back, are you aware of any update on your machine, pushed by IT for instance when a component is not the expected version ?

 

In addition to what @Patrick mentioned, can you please try to only reinstall the .NET Framework ?

From system requirements, you need Microsoft .NET Framework 3.5 Service Pack 1.

 

Hope that helps.

Cheers,
Damo

 

Solution
‎04-12-2018 05:22 PM
New Contributor
Posts: 3

Re: Failure to connect to SAS Metadata server from EG

After contacting IT I discovered that the first guy didn't reinstall the SAS EG completly. So after reinstalling it the right way it worked... Sorry for this boring solution. Thanks for your attention guys!

 

PS.: reinstalling the .NET framework had no effect at all.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 165 views
  • 2 likes
  • 3 in conversation