Desktop productivity for business analysts and programmers

Error with LASR libname statement in SAS EG

Accepted Solution Solved
Reply
Contributor
Posts: 73
Accepted Solution

Error with LASR libname statement in SAS EG

Hi masters!

 

I have a problem when trying to create a library in SAS EG. The error is the next:

 

The LASR Analytic Server on 'host name' port 10010 is running on a host platform that is not supported by your SAS client platform.

 

I have 1 machine with SAS office analytics Server and another machine with Visual Analytics. When i execute a libname statement in SAS I get the error that i told.

 

The libname statemen is like the next:

 

LIBNAME VALIBLA SASIOLA TAG=HPS PORT=10011 HOST=myhost SIGNER="http://mydomain:80/SASLASRAuthorization"

 

I try this statement with an old host and it works, but with the new host I got the error.

 

Kind regards.

 

 


Accepted Solutions
Solution
‎02-09-2018 04:59 AM
SAS Employee
Posts: 199

Re: Error with LASR libname statement in SAS EG

Posted in reply to JuanDaniel

Hi @JuanDaniel

 

when you say it works for one, not the other, is it related to the Application server context you are conencted to using Eg (SASApp vs SASVA for instance)?

 

Cheers,
Damo

View solution in original post


All Replies
SAS Employee
Posts: 199

Re: Error with LASR libname statement in SAS EG

Posted in reply to JuanDaniel

Hi @JuanDaniel

 

Did you have a look at Problem Note 57037 (Errors might occur when you use the SASIOLA engine to load data to a SAS® LASR™ Analytic Server machine) ?

 

It says:

The issue occurs if you deploy SAS® Visual Analytics or SAS® Visual Analytics Administration and Reporting with a Solution on a Windows machine with SAS Workspace Server but the SAS LASR Analytic Server is installed on another Windows machine.  This scenario is not supported currently. This limitation does not occur if the SAS LASR Analytic Server is on a Linux machine.

Are you using a similar configuration ? if yes, hopefully you can use one of the workarounds listed.

 

Hope that helps.

 

Cheers,
Damo

Contributor
Posts: 73

Re: Error with LASR libname statement in SAS EG

Thanks @Damo

 

The problem is that with 1 machine works and with other don't work.

 

Kind Regards.

Solution
‎02-09-2018 04:59 AM
SAS Employee
Posts: 199

Re: Error with LASR libname statement in SAS EG

Posted in reply to JuanDaniel

Hi @JuanDaniel

 

when you say it works for one, not the other, is it related to the Application server context you are conencted to using Eg (SASApp vs SASVA for instance)?

 

Cheers,
Damo

Contributor
Posts: 73

Re: Error with LASR libname statement in SAS EG

Hi @Damo

 

It works changing the App Server to SASVA. 

 

Thanks!!!!

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 256 views
  • 2 likes
  • 2 in conversation