Desktop productivity for business analysts and programmers

Error in auto generated pre-code in EG4.3

Reply
New Contributor
Posts: 4

Error in auto generated pre-code in EG4.3

Often, but not always when running Program nodes the following ERROR is produced in the log:

1 ;*';*";*/;quit;run;
2 OPTIONS PAGENO=MIN;
3 %_eg_hidenotesandsource;
MPRINT(_EG_HIDENOTESANDSOURCE): options nonotes;
MPRINT(_EG_HIDENOTESANDSOURCE): options nosource;
ERROR: Invalid option value ICC CMS Level 1 Data.ICC_METHOD for SAS option _LAST_.
MPRINT(_EG_RESTORENOTESANDSOURCE): options NOTES;
MPRINT(_EG_RESTORENOTESANDSOURCE): options SOURCE;

Now it appears EG is generating a reference to the last table used but is using the library description (as entered in metadata) rather than the actual libref.

The code carries on as normal but having ugly red x's on my Process Flow is not a good look. Any ideas around this or is this one for Tech Support?

Cheers,

Jono.
Trusted Advisor
Posts: 2,114

Re: Error in auto generated pre-code in EG4.3

Tech support. for sure.
Community Manager
Posts: 2,882

Re: Error in auto generated pre-code in EG4.3

Thanks for reporting this; we have are tracking this now and we expect to work a remedy into a future hotfix.

Chris
New Contributor
Posts: 4

Re: Error in auto generated pre-code in EG4.3

Thanks Chris. As previously suggested I have logged a call with Tech Support and they have pointed me to PN 41318 - so I'll keep my eye out for the hotfix. Thanks again Smiley Happy
Ask a Question
Discussion stats
  • 3 replies
  • 391 views
  • 0 likes
  • 3 in conversation