Desktop productivity for business analysts and programmers

Error from EG startup code

Reply
Occasional Contributor
Posts: 8

Error from EG startup code

We have SAS 9.4 M3. Receiving error from EG startup code. Preventing from opening output everytime. Please suggest how to resolve this error.

 

ERROR: Could not find extension: (sasgis)

 

/* ---------------------------------------------------- */

496  /* DATA step to determine whether certain products      */

497  /* are licensed/installed.                              */

498  /* ---------------------------------------------------- */

499 

500  /* Note: Use 'n' parameter to tslvl function if 9.4 M2

501  or later to avoid unnecessary warning. */

502  %macro GetTslvlParam2;

503   %if %_SAS_VERCOMP(9,4,2) >= 0 %then , 'n';

504  %mend;

505 

506  data _prodsavail;

507   length name $ 8 fullname $ 30 prodcode $ 10 prodmod $ 10 installed $ 12;

508   input fullname 1-30 name 32-39 prodcode prodmod;

509   licensed=sysprod(prodcode);

510   installed = tslvl(prodmod%GetTslvlParam2);

511  cards;

ERROR: Could not find extension: (sasgis)

 

Regular Contributor
Posts: 169

Re: Error from EG startup code

This support note looks like it addresses the issue. If that doesn't help, you may want to open a track with SAS technical support.

Occasional Contributor
Posts: 8

Re: Error from EG startup code

FYI Unchecking show wrapper code  worked.

 EG->Tools->Options->Results General->Uncheck show generated wrapper code in log
Ask a Question
Discussion stats
  • 2 replies
  • 124 views
  • 0 likes
  • 2 in conversation