Desktop productivity for business analysts and programmers

Emailing

Reply
N/A
Posts: 0

Emailing

Hi,

I'm getting the following message when trying to run the email code through E-Guide.

filename mymail email 'mrmail@mail.com' subject='test sas server email';

data _null_;
file mymail;
put 'Hi';
put 'This message is sent from the SAS Server...';
run;

NOTE: The file MYMAIL is:
E-Mail Access Device

ERROR: Unable to connect to SMTP server.
ERROR: connect call failed, system error is '10053 - WSAECONNABORTED'.

I've specified the following parameters in SASV9.CFG file
-emailsys SMTP
-emailhost mymail.server.com
-emailport 25
-emailauthprotocol=none

I've been able to manually send an email out from the SAS server by telnetting onto my mailserver on port 25.

Any ideas appreciated!

Rob
SAS Super FREQ
Posts: 8,820

Re: Emailing

Hi!
I always use TO= and FROM= when I send email. That's probably NOT your issue. It may be that contacting Tech Support is your best bet to resolve this issue.
Meanwhile, here's some reading you can do that may help, too.

TS-605 with Samples:
http://support.sas.com/techsup/technote/ts605.html

Sample program:
http://support.sas.com/ctx/samples/index.jsp?sid=467

Troubleshooting steps:
http://support.sas.com/techsup/unotes/SN/018/018363.html

Other Tech Support notes about SMTP mail:
http://support.sas.com/techsup/unotes/SN/014/014004.html
http://support.sas.com/techsup/unotes/SN/015/015228.html
http://support.sas.com/techsup/unotes/SN/006/006713.html

To contact Tech Support:
http://support.sas.com/techsup/contact/index.html

Good Luck!
cynthia
N/A
Posts: 0

Re: Emailing

Cythia,

Thanks for the response. We managed to get emailing to work. We found that our mail administrator had blocked our new server from using it as a relay host. Anyhow, that's been resolved now.

Thanks!
Ask a Question
Discussion stats
  • 2 replies
  • 172 views
  • 0 likes
  • 2 in conversation