Desktop productivity for business analysts and programmers

EG language settings & getting output in English

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

EG language settings & getting output in English

I would like help with my EG language settings and getting my results output in English.

I am using my University computer which has installed Base SAS 9.4 and EG 6.1. Base SAS runs both in Spanish and in English. I am running on Windows 7 and the default language setting for the computer is Spanish. In EG, I have clicked Tools >> Options >> General >> Enterprise Guide Language Settings and selected the current language to be English (United States), exited the EG program and then restarted EG so that the EG user interface is in English instead of the default Spanish.

However, when I run tasks, the output I get is still in Spanish, or a mixture of Spanish with English titles that are user defined. This is annoying if I want to use reports to export for use in an English only environment. See the screenshot. Instead of where "procedure", "Information on Class Levels", etc should be in English, I get "Procedimiento", "Información de nivel de clase", etc in Spanish. The title is user defined by me, hence is in English.

after1.JPG

In an effort to fix this, I saw in another similar forum discussion that I should try running some code, so I ran:


OPTIONS LOCALE=EN_US; run;

proc options group=languagecontrol; run;


The output I got (amongst other things) was:

Group=LANGUAGECONTROL

DFLANG=ENGLISH    Specifies the language for international date informats and formats.

However, the output is exactly the same as the screenshot above. No change in output language.

Can someone help me please!

Thanks so much.


Accepted Solutions
Solution
‎03-28-2014 05:14 AM
New Contributor
Posts: 4

Re: EG language settings & getting output in English

Thanks so much Jaap! Your response was very helpful.

This is what I did to solve my problem:

1. In my computer's Windows Explorer, (I will write the path name in Spanish, as it is on my computer):

C: >> Archivos de programa >> SASHome >> SASFoundation >> 9.4

2. I found a file called sasV9.cfg which has configuration information for BASE SAS.

3. I used a SAS text editor and changed the language from "es" to "en",

that is I changed:

-config "C:\Program Files\SASHome\SASFoundation\9.4\nls\es\sasv9.cfg"

to

-config "C:\Program Files\SASHome\SASFoundation\9.4\nls\en\sasv9.cfg"

Note: Apparently you can use NotePad to make this change although I didn't try, but do NOT use MS Word.

4. Saved the updated sasV9.cfg file.

5. Reopened Enterprise Guide... and it worked. Now all the outputs now come out in English.

Thanks again!

View solution in original post


All Replies
Valued Guide
Posts: 3,206

Re: EG language settings & getting output in English

As you ar running Eguide to the Windows-version SAS, many help/language files are set by the SAS-config option.

What is the default SAS version started (config-en or config_esp) by Eguide?

Eguide starts the SAS process using a windows-registry. That one is normal the sas command - language version like you have typed "SAS" in a prompt.  

---->-- ja karman --<-----
Solution
‎03-28-2014 05:14 AM
New Contributor
Posts: 4

Re: EG language settings & getting output in English

Thanks so much Jaap! Your response was very helpful.

This is what I did to solve my problem:

1. In my computer's Windows Explorer, (I will write the path name in Spanish, as it is on my computer):

C: >> Archivos de programa >> SASHome >> SASFoundation >> 9.4

2. I found a file called sasV9.cfg which has configuration information for BASE SAS.

3. I used a SAS text editor and changed the language from "es" to "en",

that is I changed:

-config "C:\Program Files\SASHome\SASFoundation\9.4\nls\es\sasv9.cfg"

to

-config "C:\Program Files\SASHome\SASFoundation\9.4\nls\en\sasv9.cfg"

Note: Apparently you can use NotePad to make this change although I didn't try, but do NOT use MS Word.

4. Saved the updated sasV9.cfg file.

5. Reopened Enterprise Guide... and it worked. Now all the outputs now come out in English.

Thanks again!

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 2217 views
  • 3 likes
  • 2 in conversation