Desktop productivity for business analysts and programmers

EG job running issue!

Reply
Regular Contributor
Posts: 152

EG job running issue!

[ Edited ]

Hi Expert,

I have a EG project only contain one single process flow. Within that single process flow, it has 171 tasks (like query builder etc.).

 

When I clicked Run project or Run proocess flow, I can see from left bottom corner, only 39 of them get submitted and executed whereas the rest has been ignored. I don't get any error or warning. Also I am getting message under title "Submitter", "This task "xxx" is already running" when I try to run some unruned job mannual after all 39 jobs completed.

 

 

 

The project was created in EG5.1 and now we are trying to migrate it into EG7.11.

 

I open the project (created in EG5.1) using EG7.11 (migration) directly.

 

The project is running fine in EG5.1.

 

 

THANKS!

Super User
Posts: 19,167

Re: EG job running issue!

So what's going wrong? 

 

You may have comditional logic that only executes specific steps depending on a specified criteria. 

Do you get red x's by any tasks?

Regular Contributor
Posts: 152

Re: EG job running issue!

I don't get any error or warning. Also I am getting message under title "Submitter", "This task "xxx" is already running" when I try to run some unruned job mannual after all 39 jobs completed.
Respected Advisor
Posts: 4,137

Re: EG job running issue!

You will need to give us a bit more detail of what's going wrong. Do you get any sort of error or it just doesn't do it.

 

Have you checked the log to see if there is any explanation of why steps don't get executed.

 

Not sure if relevant for your case but adding the following 2 links anyway:

https://communities.sas.com/t5/SAS-Enterprise-Guide/Order-of-programs-in-SAS-EG/td-p/147405

http://support.sas.com/kb/57/116.html

 

Frequent Learner
Posts: 1

Re: EG job running issue!

[ Edited ]

I am having the same issue.

It happend after i killed EG the hard way via Task manager in Windows.

 

A certain proc export step (of hundreds) would not run (the export file was locked) so i closed EG the hard way.

Ofter opening the project it will not go beyond this step.

So al following steps give the error message 'this task xxx is already running'.

 

It seems the SAS EG project is now corrupt.

 

I am running SAS EG 7,1 with all the updates.

I am running locally (so no servers or metadata or .....)

Apparently SAS EG is having a check list which processes it should run. However these processes are not yellow and you can not cancel or kill them anymore.

any ideas?

 

 

Super User
Posts: 3,237

Re: EG job running issue!

Restore your project from a backup created before the corruption.

Ask a Question
Discussion stats
  • 5 replies
  • 344 views
  • 0 likes
  • 5 in conversation