Desktop productivity for business analysts and programmers

EG 7.13 slow to respond to keystrokes

Reply
Occasional Contributor
Posts: 6

EG 7.13 slow to respond to keystrokes

When writing SAS code in EG there is a noticible latency between each keystroke. It takes up to 0.5s for the key press to register and appear on the screen. Any ideas how this could be solved? No other application suffers from the same problems (including SAS enchanced editor).

 

I am currenlty using SAS EG 7.13 running on a remote server within my local company network (it is more powerful than my computer) running windows 7 Pro to which I connect using Remote Desktop. I have switched off code auto completion and collapsable code sections.

Community Manager
Posts: 2,884

Re: EG 7.13 slow to respond to keystrokes

As you are connecting to a remote session (using Citrix or Terminal Server), you might need to adjust the settings of the connection (tweaking how the graphics rendering is done).  Some of this is controllable from your end, adjusting the properties of the connection.  Some might need to be adjusted by an admin (Citrix).  EG and some other Windows apps use WPF for some of the user interface (this includes the editor).

 

You can try the steps in this paper -- a bit old, but might still be relevant.

Occasional Contributor
Posts: 6

Re: EG 7.13 slow to respond to keystrokes

Thanks for your reply. I have tried steps described in the paper and they did not make a difference. I will look deeper into settings on the server side. Any ideas what I should be looking for?

 

I have tried many cobinations of settings on the client and the only thing that seems to make a difference is font smoothing (decreases the latency slightly but still not as quick as other applications).

New Contributor
Posts: 2

Re: EG 7.13 slow to respond to keystrokes

Hi Jakub,

Serveral team members are having the slow keystroke issue in my team and we use SAS EG 6.1 for SAS 9.4A and I was wondering if you were able to resolve this issue?

 

Thanks,
Edik

SAS Super FREQ
Posts: 305

Re: EG 7.13 slow to respond to keystrokes

[ Edited ]

The EG editor's syntax suggestion/autocompletion feature could be the cause of this slowdown -- especially in older EG releases and with larger programs.  You could try turning it off (uncheck Enable Autocomplete in Program menu->Editor Options->Autocomplete tab).  If that is the cause, you should see a marked improvement.  (This particular issue has been largely addressed in newer EG releases.)

 

(Though I just noticed @jakub_deka had already tried disabling Autocompletion.  It is still the first thing I would try for slow keystrokes, since it has been the culprit for at least a couple cases.)

 

Casey

Occasional Contributor
Posts: 6

Re: EG 7.13 slow to respond to keystrokes

Sadly I have been unable to resolve this issue. As mentioned before I have tried disabling code completion (which does increase latency for large SAS files), changing connection settings to the remote server and disabling/enabling hardware acceleration.

 

This has not resolved the issue completely, however with code completion disabled EG is usable. Just nowehere near as responsive as any other application.

 

If the delay gets longer as your SAS program, gets longer, then disabling Autocomplete will fix it.

New Contributor
Posts: 2

Re: EG 7.13 slow to respond to keystrokes

Thank you Casey and Jakub for your responses! Will give Autocomplete a try and let you guys know how it goes!
Ask a Question
Discussion stats
  • 6 replies
  • 383 views
  • 0 likes
  • 4 in conversation