Desktop productivity for business analysts and programmers

EG 7.12 syserrortext

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

EG 7.12 syserrortext

On running %put &syserrortext; from a SAS EG 7.1 program window + connecting to a SAS 9.2 server (Windows OS) the result is:

13-12: Unrecognized SAS option name, TIMEZONE.

Is there a way to prevent this ERROR from populating the syserrortext macro variable?

 


Accepted Solutions
Solution
‎07-28-2016 11:06 AM
SAS Super FREQ
Posts: 271

Re: EG 7.12 syserrortext

I noticed that second error in the initialization log (for 9.2 servers) as well.  It is also a result of setting an option (VALIDMEMNAME) that did not exist in 9.2.  (VALIDMEMNAME was added in SAS 9.3.)  Yes, you can prevent EG (6.1M1 or later) from setting the VALIDMEMNAME system option by setting the Tools->Options->Data->Data General->Naming Options->Valid member names option to Use setting from server.

 

Casey

View solution in original post


All Replies
SAS Super FREQ
Posts: 676

Re: EG 7.12 syserrortext

Hi

 

The SYSERRORTEXT will always contain the last error message written to log. Do not look at this variable alone, but also consider checking SYSERR o others.

 

There is a way to set a custom text, see example below

 

proc print data=sashelp.sugus2;
run;

%put NOTE: &=syserrortext;

%put ERROR: _NOTSET_;

%put NOTE: *&syserrortext*;

But I guess it is better to check the root cause of your error.

 

Bruno

New Contributor
Posts: 4

Re: EG 7.12 syserrortext

In an EG session I have tried:

%put ERROR: . ;

and this sets the value of syserrortext to blank. However it creates an error condition in the project window.

I have further discovered that if I create an enterpriseguide.sas file containing the enterpriseguide macro this can be modified to include:

%if "&sysver" = "9.2" %then %do ;
  %put ERROR: . ;
%end ;

This works + does not create an error in the EG project window.

SAS Super FREQ
Posts: 676

Re: EG 7.12 syserrortext

Hi

 

In the code that is submitted when EG connects to a SAS Server the following code is run, see below, to set the timezone of the SAS Server to the timezone of the EG. Since this is not supported for SAS9.2, you will get the error.

 

/* ---------------------------------- */
/* OPTION: TIMEZONE                   */
/* PURPOSE: set the server to use     */
/*   the same time zone as the client */
/* ---------------------------------- */
OPTIONS TIMEZONE="GMT+02:00";

Bruno

SAS Super FREQ
Posts: 271

Re: EG 7.12 syserrortext

The error you are seeing is most likely due to a change made in EG 7.11 in the initialization code that EG submits when connecting to a workspace server.  EG now sets the TIMEZONE system option as part of its server initialization code, so that the server and client timezone's are synced.  However, the TIMEZONE option did not exist in 9.2, so you'll likely see this error in your server initialization log:

 

82 /* ---------------------------------- */

83 /* OPTION: TIMEZONE */

84 /* PURPOSE: set the server to use */

85 /* the same time zone as the client */

86 /* ---------------------------------- */

87 OPTIONS TIMEZONE="GMT-04:00";

________

13

ERROR 13-12: Unrecognized SAS option name, TIMEZONE.

 

You can confirm by looking at your server initialization log with these steps:

  1. Navigate to EG's Servers view.
  2. Connect to your workspace server (ex. SASApp) if not already connected.
  3. Right-click the workspace server and select the Properties context menu item.
  4. On the Software tab, click View Initialization Log.

 

Note: There is a config file option called "SuppressTimezone" you can use to prevent EG from setting the TIMEZONE.  For example, put this in your SEGuide.exe.config file in the EG installation directory:

 

  <appSettings>

    <add key="SuppressTimezone" value="true" />

  </appSettings>

 

(Make sure to uncomment the appSettings section, as it is commented out initially.)

 

ps- Just noticed as I was typing this Bruno found the TIMEZONE setting as well.

New Contributor
Posts: 4

Re: EG 7.12 syserrortext

I confirm that the timezone error occurs in the SAS 9.2 workspace server initialization log. However another error is also present relating to:
options validvarname=ANY validmemname=EXTEND;
ERROR 13-12: Unrecognized SAS option name, VALIDMEMNAME.
ERROR 13-12: Unrecognized SAS option name, TIMEZONE.
After adding the SuppressTimezone key to the SEGuide.exe.config file the TIMEZONE error disappears.
However on running the syserrortext code we now get:
ERROR 13-12: Unrecognized SAS option name, VALIDMEMNAME.
Is there a way to suppress the VALIDMEMNAME option as well?

Solution
‎07-28-2016 11:06 AM
SAS Super FREQ
Posts: 271

Re: EG 7.12 syserrortext

I noticed that second error in the initialization log (for 9.2 servers) as well.  It is also a result of setting an option (VALIDMEMNAME) that did not exist in 9.2.  (VALIDMEMNAME was added in SAS 9.3.)  Yes, you can prevent EG (6.1M1 or later) from setting the VALIDMEMNAME system option by setting the Tools->Options->Data->Data General->Naming Options->Valid member names option to Use setting from server.

 

Casey

New Contributor
Posts: 4

Re: EG 7.12 syserrortext

I have tested the combination of turning VALIDMEMNAME off and SuppressTimezone appsettings and this has successfully resulted in syserrortext being blank and no errors in the workspace server initialisation log when using a SAS 9.2 server with EG 7.12. Excellent work! Thank you to all the contributors to this post.

 

best regards - Rod McMillan

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 429 views
  • 0 likes
  • 3 in conversation