Desktop productivity for business analysts and programmers

EG 7.1 Tasks - Each reconnecting to server

Reply
Regular Contributor
Posts: 163

EG 7.1 Tasks - Each reconnecting to server

Our company has recently removed the ability to run SAS EG on our local server (on the PC). Everything must now be run on the SAS server.  Since migrating all of my EG projects over, the time it takes for each process flow to run is much longer.  I am noticing that each task in the process flow has to connect to the server before it runs.  This seems to be a major time killer.  Is there a way allow this process flow to run without each task having to connect?  I am connected to the server via the EG profile so I am not sure why these tasks have to connect on their own.

 

Thanks!

Community Manager
Posts: 3,462

Re: EG 7.1 Tasks - Each reconnecting to server

Posted in reply to elwayfan446

There should be just one connection made to a Workspace initially, when the first task runs.  (If different connections/workspaces were used, you would not be able to rely on WORK tables and macro variables that are assigned in early tasks.)

 

Make sure that your project is not set up for parallel execution, as that will spawn off additional connections and probably won't save you time.

 

If you are using SAS Grid Computing, there might be some additional work going on to connect to various grid nodes along the way.  We would need to know more about your setup to say for sure.

Regular Contributor
Posts: 163

Re: EG 7.1 Tasks - Each reconnecting to server

Posted in reply to ChrisHemedinger

@ChrisHemedingerthank you for the reply.

 

I have verified that parallel processing is not turned on in my project.  I am not sure exactly how our environment is set up on the server side, I would have to get with our server team to find out. 

 

I will clarify what I am seeing. If I run the process flow, each task acts as if it is connecting to the workspace server.  You are right, I don't think it literally disconnects because there don't seem to be any issues with using the work library or the process flow dropping my variables I have set in the first task.  It is very strange but this is definitely slowing down the execution.   I attached a screenshot.

 

 

2017-12-12_8-50-47.jpg

 

Community Manager
Posts: 3,462

Re: EG 7.1 Tasks - Each reconnecting to server

Posted in reply to elwayfan446

You may need to turn on Application Logging (Tools->Options) and supply those diagnostics to SAS Technical Support.  They may be able to chase down where the latency is occurring.

Regular Contributor
Posts: 163

Re: EG 7.1 Tasks - Each reconnecting to server

Posted in reply to ChrisHemedinger

I was afraid of that.  Unfortunately for me, I have to send this up the chain in my company.  More than likely, they won't know either and they will have to contact SAS.  I may be way down on the priority list for that.

Ask a Question
Discussion stats
  • 4 replies
  • 232 views
  • 0 likes
  • 2 in conversation