Desktop productivity for business analysts and programmers

EG 4.3 autocomplete off by one

Accepted Solution Solved
Reply
PROC Star
Posts: 1,291
Accepted Solution

EG 4.3 autocomplete off by one

Hi All,

I just noticed having an odd problem with EG code autocomplete.  It seems to be off by one.

So if I type &file and hit space, it selects &extension, and replaces it.

file.jpg

If I start to type &method , after I have typed &me it guesses I'm typing &just

method.jpg

Any idea what could be going wrong?  I have quit and restarted EG. And turned autocomplete off and on.   Seems to be happening only in one program in the project.

Thanks,

--Q.


Accepted Solutions
Solution
‎09-24-2012 11:59 AM
Community Manager
Posts: 2,889

Re: EG 4.3 autocomplete off by one

Hi Quentin,

It looks like you have some "interesting" macro variables at least as far as EG detects (with "Fileref|Filename|Filepath").  Still could be an off-by-one issue in the editor, but perhaps only with your "special mix" of macro variables?

Chris

View solution in original post


All Replies
Solution
‎09-24-2012 11:59 AM
Community Manager
Posts: 2,889

Re: EG 4.3 autocomplete off by one

Hi Quentin,

It looks like you have some "interesting" macro variables at least as far as EG detects (with "Fileref|Filename|Filepath").  Still could be an off-by-one issue in the editor, but perhaps only with your "special mix" of macro variables?

Chris

PROC Star
Posts: 1,291

Re: EG 4.3 autocomplete off by one

You are right Chris.  I should have paused to guess at why the autocomplete thought there were some odd macro vars.  I'm in the habit of commenting my macro variables as below:

%global 
  file /* Fileref|Filename|Filepath/filename */
  method
  ;

While SAS respects those comments, looks like EG autocomplete word scanner (?) thinks everything before the semicolon is the name of a macro var, as in below simple example.

Guess some of that junk was tripping up how it autcompletes, causing the off-by-one (not shown below).  When I took out the comments, it started working again.

Thanks much!autcomplete.jpg

Community Manager
Posts: 2,889

Re: EG 4.3 autocomplete off by one

Thanks for confirming.  I'll pass that on the EG development team so they can investigate.

Chris

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 193 views
  • 0 likes
  • 2 in conversation