Desktop productivity for business analysts and programmers

Custom Macro Abbreviations - disable Autocomplete

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

Custom Macro Abbreviations - disable Autocomplete

I made this abbreviation called example: 

 

CASE WHEN t1.INFORMATION_DT=&DATE_T0 THEN 'T0'

But, autocomplete won't work, when i type example, it won't show up, but when i start typing CASE and hit enter, it runs this macro, and this is not what i want.

How can i disable autocomplete only for this custom macro abbrevations? 
In that way, i will prevent running this macro every time i start typing CASE WHEN, and i will be able to use ctrl + shift + b to choose abbreviation from a list.

I use SAS EG 7.14. 


Accepted Solutions
Solution
3 weeks ago
SAS Super FREQ
Posts: 401

Re: Custom Macro Abbreviations - disable Autocomplete

Posted in reply to sasuser381

What exact version of EG do you have (the version listed in EG's Help->About box)?  (There is no EG 7.14.)

 

I have not been able to reproduce what you described in EG 7.15 HF3.  I created an abbreviation macro with the name "example" and the text you provided below.  In an empty editor, when I start typing "example", the abbreviation macro appears in the syntax suggestion popup and works as expected (inserts the text).  However, if I first type "proc sql; select " and then type "example" (in the select statement), the abbreviation macro does not appear in the syntax suggestion popup.  Ctrl+Shift+B will bring up the list with the EXAMPLE abbreviation macro available and I confirmed it works.  If I type "CASE" after "proc sql; select " and then hit enter, it does not run the abbreviation macro for me.

 

Please provide as simple code as possible (and instructions) that you are able to use to reproduce, so I can attempt to reproduce.

 

Thanks,

Casey

View solution in original post


All Replies
Solution
3 weeks ago
SAS Super FREQ
Posts: 401

Re: Custom Macro Abbreviations - disable Autocomplete

Posted in reply to sasuser381

What exact version of EG do you have (the version listed in EG's Help->About box)?  (There is no EG 7.14.)

 

I have not been able to reproduce what you described in EG 7.15 HF3.  I created an abbreviation macro with the name "example" and the text you provided below.  In an empty editor, when I start typing "example", the abbreviation macro appears in the syntax suggestion popup and works as expected (inserts the text).  However, if I first type "proc sql; select " and then type "example" (in the select statement), the abbreviation macro does not appear in the syntax suggestion popup.  Ctrl+Shift+B will bring up the list with the EXAMPLE abbreviation macro available and I confirmed it works.  If I type "CASE" after "proc sql; select " and then hit enter, it does not run the abbreviation macro for me.

 

Please provide as simple code as possible (and instructions) that you are able to use to reproduce, so I can attempt to reproduce.

 

Thanks,

Casey

New Contributor
Posts: 4

Re: Custom Macro Abbreviations - disable Autocomplete

Posted in reply to CaseySmith

I tried it in an empty editor, and then it runs the macro abbreviation after typing "case".
I should  have done that after "proc sql; select". Now it is ok.
So that was what i wanted. Thank you Casey.

The other problem that remains is that it still won't show up in syntax suggestions. 

I use SAS EG 7.11. HF3

Thanks,

Nada

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 98 views
  • 0 likes
  • 2 in conversation