Desktop productivity for business analysts and programmers

Course data files do not show up in SAS Enterprise Miner after assigning a library

Accepted Solution Solved
Reply
Contributor
Posts: 24
Accepted Solution

Course data files do not show up in SAS Enterprise Miner after assigning a library

Hi there!

 

I wanna apply SVM to the dataset uscrime.txt using SAS OnDemand for Academics - Enterprise Miner.

I followed all the steps on the User's Guide but my data files are NOT showing up and I'm unable "Create Data Source".

 

Here's what I did so far:

1) Started SAS Studio available on my dashboard: https://odamid.oda.sas.com/SASODAControlCenter/index.html

2) Uploaded files to mycontent folder as it appears in the pic:

Captura de Tela 2018-06-12 às 3.53.05 PM.png

 

3) Assigned the library hmw to the mycontent folder and it's correctly showing up like this:

Captura de Tela 2018-06-12 às 4.01.31 PM.png

 

4) Then I started Enterprise Miner (I've heard it does not work on my MAC but I'm using parallels to run it on Windows 10.. I also downloaded  JAVA 8 v45 as recommended). I created a new project and inserted on the Project Start Code the following: 

libname hmw "/home/mac60/my_content/";

5) The above line runs and returns the log: 

NOTE: Libref HMW was successfully assigned as follows: 
      Engine:        V9 
      Physical Name: /courses/d309ad4dba27fe300
95 The SAS System                                                                                                                                                                                                           Wednesday, June 13, 2018 12:50:00 A
M

238562     %let SYSCC=0;
238563     %let SYsrc=0;
238564     %let EMEXCEPTIONSTRING=;
238565     %let SYSMSG=;
238566     /*; *"; *'; */; quit; %let syscc=0;

6) When I try to browse the data file from my hmw library, no file shows up (I've tried both SAS Table and Metadata Repository). Here's a print:

Captura de Tela 2018-06-12 às 4.06.47 PM.png

 

 

Can someone help me? I've been stuck with this the whole day today =/ 


Accepted Solutions
Solution
Wednesday
Super User
Posts: 23,244

Re: Course data files do not show up in SAS Enterprise Miner after assigning a library

Posted in reply to marianaalcos

Those are text and excel files. You have to import them to convert them to SAS data sets before they'll show up in a library, or you can use SAS PROCS on the data sets. I don't recall how to do that in EM, you may need to first use SAS Studio to convert them and load them up to your library. 

 

You can use SAS EM on a MAC but also need to install the correct Java versions and such. I got it working once Smiley Happy

 


@marianaalcos wrote:

Hi there!

 

I wanna apply SVM to the dataset uscrime.txt using SAS OnDemand for Academics - Enterprise Miner.

I followed all the steps on the User's Guide but my data files are NOT showing up and I'm unable "Create Data Source".

 

Here's what I did so far:

1) Started SAS Studio available on my dashboard: https://odamid.oda.sas.com/SASODAControlCenter/index.html

2) Uploaded files to mycontent folder as it appears in the pic:

Captura de Tela 2018-06-12 às 3.53.05 PM.png

 

3) Assigned the library hmw to the mycontent folder and it's correctly showing up like this:

Captura de Tela 2018-06-12 às 4.01.31 PM.png

 

4) Then I started Enterprise Miner (I've heard it does not work on my MAC but I'm using parallels to run it on Windows 10.. I also downloaded  JAVA 8 v45 as recommended). I created a new project and inserted on the Project Start Code the following: 

libname hmw "/home/mac60/my_content/";

5) The above line runs and returns the log: 

NOTE: Libref HMW was successfully assigned as follows: 
      Engine:        V9 
      Physical Name: /courses/d309ad4dba27fe300
95 The SAS System                                                                                                                                                                                                           Wednesday, June 13, 2018 12:50:00 A
M

238562     %let SYSCC=0;
238563     %let SYsrc=0;
238564     %let EMEXCEPTIONSTRING=;
238565     %let SYSMSG=;
238566     /*; *"; *'; */; quit; %let syscc=0;

6) When I try to browse the data file from my hmw library, no file shows up (I've tried both SAS Table and Metadata Repository). Here's a print:

Captura de Tela 2018-06-12 às 4.06.47 PM.png

 

 

Can someone help me? I've been stuck with this the whole day today =/ 


 

View solution in original post


All Replies
Solution
Wednesday
Super User
Posts: 23,244

Re: Course data files do not show up in SAS Enterprise Miner after assigning a library

Posted in reply to marianaalcos

Those are text and excel files. You have to import them to convert them to SAS data sets before they'll show up in a library, or you can use SAS PROCS on the data sets. I don't recall how to do that in EM, you may need to first use SAS Studio to convert them and load them up to your library. 

 

You can use SAS EM on a MAC but also need to install the correct Java versions and such. I got it working once Smiley Happy

 


@marianaalcos wrote:

Hi there!

 

I wanna apply SVM to the dataset uscrime.txt using SAS OnDemand for Academics - Enterprise Miner.

I followed all the steps on the User's Guide but my data files are NOT showing up and I'm unable "Create Data Source".

 

Here's what I did so far:

1) Started SAS Studio available on my dashboard: https://odamid.oda.sas.com/SASODAControlCenter/index.html

2) Uploaded files to mycontent folder as it appears in the pic:

Captura de Tela 2018-06-12 às 3.53.05 PM.png

 

3) Assigned the library hmw to the mycontent folder and it's correctly showing up like this:

Captura de Tela 2018-06-12 às 4.01.31 PM.png

 

4) Then I started Enterprise Miner (I've heard it does not work on my MAC but I'm using parallels to run it on Windows 10.. I also downloaded  JAVA 8 v45 as recommended). I created a new project and inserted on the Project Start Code the following: 

libname hmw "/home/mac60/my_content/";

5) The above line runs and returns the log: 

NOTE: Libref HMW was successfully assigned as follows: 
      Engine:        V9 
      Physical Name: /courses/d309ad4dba27fe300
95 The SAS System                                                                                                                                                                                                           Wednesday, June 13, 2018 12:50:00 A
M

238562     %let SYSCC=0;
238563     %let SYsrc=0;
238564     %let EMEXCEPTIONSTRING=;
238565     %let SYSMSG=;
238566     /*; *"; *'; */; quit; %let syscc=0;

6) When I try to browse the data file from my hmw library, no file shows up (I've tried both SAS Table and Metadata Repository). Here's a print:

Captura de Tela 2018-06-12 às 4.06.47 PM.png

 

 

Can someone help me? I've been stuck with this the whole day today =/ 


 

Contributor
Posts: 24

Re: Course data files do not show up in SAS Enterprise Miner after assigning a library

Hi Reeza!

You've saved me once again, thank you thank you THANK YOU! It worked just fine!

I'm using it on my MAC too. I guess with the proper java (I'm using v8 _45 as recommended) it works well. I'll report if I encounter issues Smiley Happy
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 93 views
  • 1 like
  • 2 in conversation