Desktop productivity for business analysts and programmers

Change language when export to CSV

Posts: 20

Change language when export to CSV

Dear All

I have got a problem with thai language when I export file from E-guide in excel format, and link to Oracle DBMS to import this export file to the table automatically. The problem is when I export file It is some time show Thai properly, but it  sometimes show unreadable language. When it links to Oracle DBMS ,the import process wont be the problem if the original file is exported and readable in Thai. if not, the error will be shown and the import process will be failed. Is it possible to export CSV. file and make it readable in Thai permanently without configure in RDBMS everytime. Do I have to change any setting in EG?

Super User
Posts: 5,917

Re: Change language when export to CSV

Posted in reply to cmajorros

Since we are dealing with computers, there is no real random results.

So if you get different results, you need to find out what is different between your executions (client PC, user id, server settings, source data...).

If this has something to do with SAS, it's likely to be a locale setting. You say Excel and csv, which one is it?

If csv, open the different files in notepad, select File - Save as...

What does the Encoding option say?

How do you create the file, using SAS server (PROC EXPORT...?) or by an EG task? If EG task, the local PC locale setting can affect.

Data never sleeps
Super User
Posts: 4,024

Re: Change language when export to CSV

Posted in reply to cmajorros

At what point does it show up as unreadable - in SAS or in Excel? For Thai to display correctly you need to use a Thai font, for example Angsana New. English-style fonts like Arial will show rubbish.

If the problem is in Excel, try changing the font used for the Thai text columns to Angsana New. Thai fonts are available in most recent versions of MS Windows / Office.

Trusted Advisor
Posts: 3,215

Re: Change language when export to CSV

Posted in reply to cmajorros

You have several parts in your proces.

1/ Eguide that is your front end interface is supporting utf8 as it is build in .NET.

2/ your sas system base/foundation is the one that executes the code can run in single byte mostly Latin1.  It can also run in utf8 mode but in that case it should use other binaries. When it is on a server the SAS APP setting scripting os is the one doing that switch.

3/ there is an Access to oracle client software installed that must support the utf8 or the Latin1 encoding. This one is communicating with

4/ the oracle server and that database having defined some encoding fir the database and tables

Having issues with thai you are most likely into some wrong configuration in the 2,3,4 aligning.

Not an eguide issue but things that are used behind those.

---->-- ja karman --<-----
Ask a Question
Discussion stats
  • 3 replies
  • 4 in conversation