Desktop productivity for business analysts and programmers

Anyone else noticed issue with syntax highlighting when using find/replace?

Reply
New Contributor
Posts: 2

Anyone else noticed issue with syntax highlighting when using find/replace?

I've recently upgraded from Enterprise Guide 6.1 to 7.13, which means that I now have the "smart highlighting" functionality. However, what I have discovered is that if I use Find (CTRL+f) to search my code in the program editor window, then the syntax highlighting goes wrong when the search result is either in a comment or within quotes. When the highlighted search result is within a comment, the entire rest of the code becomes green, like a comment (using the default syntax highlighting colour scheme). Similarly, if the search result is within quotes, all the following code becomes purple, like text within quotes.

 

I can remove this buggy behaviour by unticking "Enable mart highlighting" - "For find/replace search" in the Editor options. But it seems a shame to turn off new functionality before I've even figured out how it can be useful!

 

Has anyone else experienced this bug? I couldn't find an Issue or a hot fix for it.

Grand Advisor
Posts: 17,360

Re: Anyone else noticed issue with syntax highlighting when using find/replace?

If you haven't already consider reporting this to tech support. Especially since it's a new feature. 

New Contributor
Posts: 2

Re: Anyone else noticed issue with syntax highlighting when using find/replace?

Thanks Reeza. I have raised it with Tech Support today and it looks to be a defect that hadn't previously been identified.

Ask a Question
Discussion stats
  • 2 replies
  • 134 views
  • 2 likes
  • 2 in conversation