Desktop productivity for business analysts and programmers

Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?

Reply
Contributor jp
Contributor
Posts: 29

Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?

Are there any ways to improve readability of data stored as hex values in EG?

 

I prefer to use EG because I find the readability/code editor more user friendly than base SAS but the display of this data as a bunch of ascii text makes it less than ideal.

 

Obviously I can read in the formats, but since swapping between 32/64bit format issues are an on-going pain I'd like to know I'm looking at "a1"x not "å" as a bit of a stop gap measure to alleviate the burden and at least make it on par with Base SAS.

Super User
Posts: 7,462

Re: Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?

Assign $HEX formats to your strings.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Contributor jp
Contributor
Posts: 29

Re: Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?

I'm getting a type of productionised data from the business, so it's not as if I can easily change the process.

Also since there is no issue in Base SAS there is little desire to change the existing way things are done.
SAS Super FREQ
Posts: 306

Re: Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?

I believe this undocumented config file option will accomplish what you desire...

 

If you open the SEGuide.exe.config file in the EG installation directory (ex. C:\Program Files\SASHome\SASEnterpriseGuide\7.1), you'll see a commented-out "appSettings" element.  Remove the comment region demarcators ("<!--" and "-->") from around the appSettings element and specifiy the key "FormatValuesAsNeeded" with the value "false".  It should look like this:

 

<appSettings>
  <add key="FormatValuesAsNeeded" value="false" />
</appSettings>

 

Now, after you save the SEGuide.exe.config file and restart EG, that config file option will instruct EG to read the formatted values directly from the server rather than formatting the raw values just-in-time (as a performance enhancement for wide data).

 

Casey

Contributor jp
Contributor
Posts: 29

Re: Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?

I'm using 5.1, and could upgrade to 6.4. I don't see this commented code in the config file - I will try adding it to the XML to see if it helps.

SAS Super FREQ
Posts: 306

Re: Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?

Yeah, the appSettings stub wasn't included in the EG 5.1 SEGuide.exe.config file, but the option does work in 5.1.  You should be able to copy the appSettings example above and paste it immediately above the </configuration> line in the SEGuide.exe.config file.

Contributor jp
Contributor
Posts: 29

Re: Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?

Hmm so I might have been unclear, but if I'm reading a dataset stored locally which needs the hex formats to be %include-d in, this fix won't solve the issue correct?

Super User
Posts: 7,462

Re: Any way to fix display errors (Ï¥@ etc..) when looking at hex values in SAS EG?


CaseySmith wrote:

Yeah, the appSettings stub wasn't included in the EG 5.1 SEGuide.exe.config file, but the option does work in 5.1.  You should be able to copy the appSettings example above and paste it immediately above the </configuration> line in the SEGuide.exe.config file.


Could it be that the same would work in version 4.3, or was that option added later in the EG code with version 5?

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Ask a Question
Discussion stats
  • 7 replies
  • 143 views
  • 0 likes
  • 3 in conversation