Desktop productivity for business analysts and programmers

A connection couldn't be made to the requested resource

Reply
Occasional Contributor
Posts: 12

A connection couldn't be made to the requested resource

Hellow  SAS Users/Experts,

Well,

I am getting this kind of error when I try to click open the folder under server tree.(SAS EG 4.3 on unix server)

Any help will be appreciated.

Here, is the Detailed Error.

Error] Failed to start the server.

------------------------------ Technical Information Follows ------------------------------

SAS.EG.SDS.SDSException: <?xml version="1.0" ?><Exceptions><Exception><SASMessage severity="Error">Failed to start the server.</SASMessage></Exception></Exceptions> ---> System.Runtime.InteropServices.COMException (0x80004011): <?xml version="1.0" ?><Exceptions><Exception><SASMessage severity="Error">Failed to start the server.</SASMessage></Exception></Exceptions>

   at SASObjectManager.ObjectFactoryMulti2Class.CreateObjectByLogicalNameAndLogins(String Name, Boolean synchronous, Object pIOMI, String LogicalName, LoginDef pOMRLoginDef, LoginDef pSASLoginDef, String nameValuePairs)

   at SAS.EG.SDS.Model.Server.Connect(ConnectionInfo connInfo)

   --- End of inner exception stack trace ---

   at SAS.EG.SDS.Model.Server.Connect(ConnectionInfo connInfo)

   at SAS.EG.SDS.Model.Server.SASWorkspace()

   at SAS.EG.SDS.Views.View.DoPopulate(DisplayOperation& op)

------------------------------ End of Technical Information ------------------------------

Thanks & Regarrds

Eshan

Community Manager
Posts: 2,891

Re: A connection couldn't be made to the requested resource

The SAS object spawner was not able to start a SAS session.  A common cause for this: expired SETINIT.  See if you can launch sas on UNIX directly, or have an admin look into it for you.

Chris

Occasional Contributor
Posts: 5

Re: A connection couldn't be made to the requested resource

I also have faced with such a problem.

The reason was with rights of user on the Unix server - there were no user's folder at home directory with configuration files, usually it is generated at the user's first  login to server. We just ask user to login to server via PuTTy once and problem was fixed

Occasional Contributor
Posts: 5

Re: A connection couldn't be made to the requested resource

Overall - the problem causes because of incorrect configuration of PAM module on Unix server

It should include "session" option - something like this:

PAM module in  /etc/pam.d/sasauth

auth    include system-auth

account include system-auth

password        include system-auth

session optional        pam_mkhomedir.so skel=/etc/skel umask=0022

Because of incorrect configuration of PAM you may face with such errors:

- anybody can login without password (if "password" option is missing)

- user hasn't home directory - situation that described in the topic - if "session" option is missing

Occasional Contributor
Posts: 19

Re: A connection couldn't be made to the requested resource

Hello..

I am also started working on PAM and UNIX_SAS environment. (*PAM = Portfolio asses management). Actually I do not have much idea about PAM, Finance and banking related data !!

1. Can you please tell me that how to connect PAM to UNIX_SAS (I don't have SAS installed in my PC / they have it in unix) ?

2. Here, they are also talking about PAM accounting journals ?? I don't know what does it means in finance data??

It's looks like a horrible !!!

Thank you

Ranny

Occasional Contributor
Posts: 5

Re: A connection couldn't be made to the requested resource

Here PAM it is a "Pluggable Authentication Modules", not Portfolio asses management

PAM should be configurated on your SAS server. It haven't any special relations or connections to SAS, only profile for SAS servise, it used only to authenticate user, because sas programs on Application server are run (and EM projects are stored) under your unix user on sas server , and this user must be defined in your sas user profile (you can edit them in Management Console).

PAM settings are storing in /etc/pam.d file.

For SAS you can create special settings using servise name option, for example sasauth:

etc/pam.d/sasauth

Then you should define module types for this service (sasauth) - there are "account", "password" and "session"

For each of module types control flag shoul be setted: "requisite" , "required", "sufficient", "optional" or "Include" (a link to other PAM servise_name, usually - system-auth, a common user authentification)

Next option - Module_path (if it's special)

Then - may be some othr options

So, PAM module can be similar to this:

in file /etc/pam.d/sasauth

auth    include system-auth

account include system-auth

password        include system-auth

session optional        pam_mkhomedir.so skel=/etc/skel umask=0022

In any case your UNIX administrator should knew.

About PAM accounting journals - I don't know about it, unfortunately.

If you a telling not about authentification modules, but only about "Portfolio asses management" - what is it (a realisation) - some database? It's another topic, and, i think, related with the connection of SAS to DB, where portfolio asses data stored - Oracle, Teradata, DB2 or something other.

New Contributor
Posts: 2

Re: A connection couldn't be made to the requested resource

I have tried adding pam_mkhomedir.so to sasauth in pam.d, but it did not work. sasauth doesn't seem to be triggering the session modules at all, as far as I can tell. Cyril have you done this and gotten it to work? Having the user login once via putty works, yes. But My users don't want to have to do that...

Occasional Contributor
Posts: 5

Re: A connection couldn't be made to the requested resource

Yes, problem was solved only after our UNIX administator has configured /etc/pam.d/sasauth as above (I'm only SAS administrator, so PAM was configured by our UNIX administrators, and I posted above their solution as they answered to my request).

New Contributor
Posts: 2

Re: A connection couldn't be made to the requested resource

Well it did not work for me. After some long conversations with tech support it was determined that sasauth does not have a session hook, and can only use modules that are in the auth or account portions of PAM. There ARE some auth modules that make directories, but they are add-ins. the default ones do not. In the end I made some shell code and put it in sasenv which accomplished the same thing more or less.

N/A
Posts: 1

Re: A connection couldn't be made to the requested resource

I faced a simmilar problem on a windows server.

I granted the goup machine/users on the machine read an execute rights and that solved the problem.


Ask a Question
Discussion stats
  • 9 replies
  • 7545 views
  • 1 like
  • 6 in conversation