Building models with SAS Enterprise Miner, SAS Factory Miner, SAS Visual Data Mining and Machine Learning or just with programming

SAS Enterprise Miner's compatibility with Java 8.01 - when?

Accepted Solution Solved
Reply
N/A
Posts: 1
Accepted Solution

SAS Enterprise Miner's compatibility with Java 8.01 - when?

Do you know if SAS EM will become compatible with Java 8.01? Security is flagging my system as noncompliant since I have not upgraded to Java 8.01's


Accepted Solutions
Solution
‎02-26-2015 11:30 AM
SAS Employee
Posts: 16

Re: SAS Enterprise Miner's compatibility with Java 8.01 - when?

We are currently evaluating our Java options  - our current Java support statement can be found here:

http://support.sas.com/resources/thirdpartysupport/v94/jres.html

which states:

Note regarding the End of Public Updates for Java SE 7: SAS is
committed to providing customers with a fully supported software environment,
including our use of the JRE. It is our intent to continue this commitment at no
additional cost to the customer. We are exploring several options to achieve
this, with our key criteria being minimizing impact on our customers.

View solution in original post


All Replies
Super User
Posts: 3,250

Re: SAS Enterprise Miner's compatibility with Java 8.01 - when?

What version of EM? If it is the one that comes with SAS 9.4 then SAS provides a private version of Java, that can co-exist with more recent versions to satisfy your security folks. The private Java version is only used by SAS and the most recent version can be used by all of your other software.

Trusted Advisor
Posts: 3,212

Re: SAS Enterprise Miner's compatibility with Java 8.01 - when?

As SASkiwi is stating you should use a JPRE (isolated java version) with a local miner client.  DO NOT USE the webstart approach.
It will make you independent of a WEB-browser having a java add-on. It is the web-browser with java plug-in that is suffering from all security breaches requiring those updates.

It would be more helpful when SAS institute would promote and support that direction.

Being dependent on components not in your direct influence area (web browser desktop) is a bad situation.   
Are you able to convince those guys that in the situation of a JPRE not connected to the browser the security risks are quite different?  

---->-- ja karman --<-----
Solution
‎02-26-2015 11:30 AM
SAS Employee
Posts: 16

Re: SAS Enterprise Miner's compatibility with Java 8.01 - when?

We are currently evaluating our Java options  - our current Java support statement can be found here:

http://support.sas.com/resources/thirdpartysupport/v94/jres.html

which states:

Note regarding the End of Public Updates for Java SE 7: SAS is
committed to providing customers with a fully supported software environment,
including our use of the JRE. It is our intent to continue this commitment at no
additional cost to the customer. We are exploring several options to achieve
this, with our key criteria being minimizing impact on our customers.

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 468 views
  • 6 likes
  • 4 in conversation