Building models with SAS Enterprise Miner, SAS Factory Miner, SAS Visual Data Mining and Machine Learning or just with programming

Run time error occurred in EM,while creating an ensemble of model

Accepted Solution Solved
Reply
Regular Contributor
Posts: 190
Accepted Solution

Run time error occurred in EM,while creating an ensemble of model

I am trying to create an ensemble, but encoutered a run time error, while running through the neural network node in EM. How can i rectify it?


ensemble_fail.jpg

Accepted Solutions
Solution
‎02-29-2016 09:25 AM
SAS Super FREQ
Posts: 306

Re: Run time error occurred in EM,while creating an ensemble of model

Posted in reply to munitech4u

I'm guessing it's the HP Forest node that is causing the error.  Since that node does not produce DATA step score code, it cannot be used with the Ensemble node.

View solution in original post


All Replies
Super Contributor
Posts: 490

Re: Run time error occurred in EM,while creating an ensemble of model

Posted in reply to munitech4u

What error you get? Post the error text...

Regular Contributor
Posts: 190

Re: Run time error occurred in EM,while creating an ensemble of model

Posted in reply to mohamed_zaki
It says, run time error encountered, please check the log. But log doesn't show any error. I think towards the end I see below, which might be the reason:

47423 %let _EM_TREECONVERSION=0;
47424 data _null_;
47425 set EMWS1.EM_NODEID end=eof;
47426 where upcase(Component) ='DECISIONTREE' and CLASS = 'SASHELP.EMMODL.DECISIONTREE.CLASS';
47427 if eof then call symput('_EM_TREECONVERSION', '1');
47428 run;

NOTE: There were 0 observations read from the data set EMWS1.EM_NODEID.
WHERE (UPCASE(Component)='DECISIONTREE') and (CLASS='SASHELP.EMMODL.DECISIONTREE.CLASS');
Solution
‎02-29-2016 09:25 AM
SAS Super FREQ
Posts: 306

Re: Run time error occurred in EM,while creating an ensemble of model

Posted in reply to munitech4u

I'm guessing it's the HP Forest node that is causing the error.  Since that node does not produce DATA step score code, it cannot be used with the Ensemble node.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 1026 views
  • 0 likes
  • 3 in conversation