Building models with SAS Enterprise Miner, SAS Factory Miner, SAS Visual Data Mining and Machine Learning or just with programming

Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Reply
Contributor
Posts: 29

Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

I am taking an e-learning course, Applied Analytics Using SAS Enterprise Miner. I am getting a result for a practice in the regression model lesson different from the solusion. I followed the steps and still not getting the same result in the solution.  The problem involves tha dataset called Organics.  The practice involved is "Impute missing values, and then run the regression node." (screen 41 in the Regression Models lesson).  The number of input variables should have been 16.  I am getting a lot more (41). I do not what causes different answer.  I followed the steps as instructed.  Has anyone taken this course and experienced the same problem?  I need to resolve this issue before I can move on as the practices in later lessons depends on the answers in previous practices.

Super Contributor
Posts: 337

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

I haven't taken e-learning in a long while, but SAS courses have the solutions for all exercises.

Courses are designed so that you can move on even if you miss something. Try to locate the solutions, ideally as an XML that you can import.

Do you have the contact for an instructor on the e-learning?

Thanks,

Miguel

Contributor
Posts: 29

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Posted in reply to M_Maldonado

Thank you for your response.  The solution is part of the course. I am not getting different result. The course is a self-paced e-learning format and there is no instructor associated.

Thanks,

Hyo

Super Contributor
Posts: 337

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Sorry Hyo, I didn't catch that, are you good to go or do you need anything else?

Contributor
Posts: 29

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Posted in reply to M_Maldonado

Miguel,

I am still stuck with the problem.  I am not getting the same result.  I was looking for someone who took the same course and wanted to know how they resolved the problem.  I cannot not move forward as the next exercise use the output data from the exercise I am having problem with. I seeked the help from the SAS tech support.  They said they only assist with software installation.

Thanks, Hyo

Super Contributor
Posts: 490

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

I think i may help you ... i am familiar with this course.

But from your description ... i do not know what is your problem and in which part exactly. more details please?

And did you followed the steps in chapter three to prepare the data before jump to four directly, because it depends.

Where is the difference you get from the material in the data set itself or the imputation or the regression?

SAS Employee
Posts: 11

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Hey Park2039,

Mohamed has asked some good questions. Providing your results that differ from the course's results will help us identify the problem.

Best,

Robert

Contributor
Posts: 29

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Posted in reply to RobertBlanchard

Robert / Mohamed,

I prepared a document that inclues the steps and my result.  I tried to attach the document and the site would not allow it to upload. I tried MS word, PDF, and rtf formats.  None of them are working.  Is there a special method for uploading a file to this site? The document contains some graphics.

Thanks

Super Contributor
Posts: 337

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

click on Reply, then top right corner says "Use advanced editor".

Then at the bottom you will see the menu "Attach files". limit is 50 MB.

Contributor
Posts: 29

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Posted in reply to M_Maldonado

I used that method and it did not work.

SAS Employee
Posts: 232

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Hi park2039, so sorry - Miguel let me know the problem. We had to turn off attachments temporarily - I will fix now. Should be okay in 5 minutes - will let you know. Thanks Miguel

SAS Employee
Posts: 232

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

You should be able to upload a PDF document now - we don't allow for Word.. So sorry for the inconvenience. If you run into trouble just respond to this thread and I'll get the message

Contributor
Posts: 29

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Posted in reply to Community_Help


The attached pdf contains the steps I followed and the results.  Two practices are included - one from the Predictive Modeling and the other from from the Regression Model session.  The output from the former is used for the later as input.

Thank you for helping me out.

SAS Employee
Posts: 11

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Sorry, posted under my old SAS data mining user account (analyze_this).

Thank you Park.  I'll have a look at your attachment and get back to you.

Best,

Robert

SAS Employee
Posts: 11

Re: Problem with a practice in Applied Analytics Using SAS Enterprise Miner Class

Hey Park,

Version of SAS EM are you running?

Best,

   Robert

Ask a Question
Discussion stats
  • 23 replies
  • 861 views
  • 1 like
  • 5 in conversation