Building models with SAS Enterprise Miner, SAS Factory Miner, SAS Visual Data Mining and Machine Learning or just with programming

How to force the EM wizard to invoke it in the English mode?

Reply
N/A
Posts: 0

How to force the EM wizard to invoke it in the English mode?

When using regional settings other than English, the menu, toolbar and the wizards such as "SAS Management Console Plug-in Wizards", "Enterprise Miner wizards" will using in current specified regional settings.

How can I force all of the wizards to display in English, such as use the command line parameters to specify the en_US locale when invoking the wizards?

We are using SAS 9.2 with Enterprise Miner Desktop 6.1 in Windows.
Also, we still have using SAS 9.1.3 with Enterprise Miner 5.3 in Windows too.

Please help with thanks.
SAS Employee
Posts: 5

Re: How to force the EM wizard to invoke it in the English mode?

Posted in reply to deleted_user
Hi Novia,

you may enforce an English locale by editing the client Enterprise Miner 5.3 init file [C:\Programme\]SAS\SASAPCore\apps\EnterpriseMiner\bin\em.ini and modify the line by adding "-Duser.language=en -Duser.region=US":

CommandLineArgs= -Duser.language=en -Duser.region=US -Xms128m -Xmx1024m ...

Cheers,
Karsten
N/A
Posts: 0

Re: How to force the EM wizard to invoke it in the English mode?

Posted in reply to Karsten_SAS
Karsten,

Thanks.
But how about in SAS 9.2 with Enterprise Miner 6.1?
SAS Employee
Posts: 5

Re: How to force the EM wizard to invoke it in the English mode?

Posted in reply to deleted_user
Hi Novia,

try setting the two language options in [C:\Programme]\SAS\SASEnterpriseMinerJavaClient\6.1\bin in the file em and/or em.bat to enforce the US locale. If this does not work, please contact SAS customer support for help.

Cheers,
Karsten
Ask a Question
Discussion stats
  • 3 replies
  • 284 views
  • 0 likes
  • 2 in conversation