Building models with SAS Enterprise Miner, SAS Factory Miner, SAS Visual Data Mining and Machine Learning or just with programming

File Import in SAS Enterprise Miner

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 19
Accepted Solution

File Import in SAS Enterprise Miner

Hello there,

 

I recently found a question that when I imported an Excel file which has 12,246 rows and 77 columns via File Import node. I can view some basic statistics by exploring a particular variable. I am surpringly found that SAS only provide first 10,000 data points showing in frequency plot. And I do specify the maximum rows and columns to 100,000. Again, it only computated the first 10,000 data points, would anyone suggest what should I do in order to get the ALL data points summarized statistics, thanks in advance!


Accepted Solutions
Solution
‎07-06-2017 01:33 PM
Super Contributor
Posts: 336

Re: File Import in SAS Enterprise Miner

Hi,

I rarely use the File Import node, but I think the Explore properties are the same for all the nodes.

 

When I do data exploration in Enterprise Miner, I bump up two settings.

 

1. Click on your project name to see its properties. Your project is on the top left panel right on top of Diagrams, Data Sources, and Model packages menus.

 

Next, click on the ellipsis for Project macro variables. Change EM_ExploreOBS_MAX to be a higher number.

 

project macro variables.png

 

2. Go to Options-> Preferences. Specify Sample Method as Random and Fetch Size as Max.

Now Enterprise Miner will pick up the Max that you specified on the previous step.

 

preferences.png

 

I hope this helps!

-Miguel

View solution in original post


All Replies
Solution
‎07-06-2017 01:33 PM
Super Contributor
Posts: 336

Re: File Import in SAS Enterprise Miner

Hi,

I rarely use the File Import node, but I think the Explore properties are the same for all the nodes.

 

When I do data exploration in Enterprise Miner, I bump up two settings.

 

1. Click on your project name to see its properties. Your project is on the top left panel right on top of Diagrams, Data Sources, and Model packages menus.

 

Next, click on the ellipsis for Project macro variables. Change EM_ExploreOBS_MAX to be a higher number.

 

project macro variables.png

 

2. Go to Options-> Preferences. Specify Sample Method as Random and Fetch Size as Max.

Now Enterprise Miner will pick up the Max that you specified on the previous step.

 

preferences.png

 

I hope this helps!

-Miguel

New Contributor
Posts: 3

Re: File Import in SAS Enterprise Miner

In order to load local data into SAS Enterprise Miner OnDemand, follow these steps:

1) Create a SAS Enterprise Miner Project

2) Create a new diagram

3) From the "Sample" tab add a "File Import" node to your new diagram

 
4) Select the "File Import" node on the diagram and from the properties panel click on the "..." beside the "Import File" option in the "Train" section.
 
 
 
 
 
 
 

5) Select "My Computer" and click on "Browse..."

 

6) Select the file you are interested in (possible file types are shown below) and click "OK" (watch out it may take a little while for this step to complete). The easiest format to use is a comm-separated file where the first row contains comma separated variable names.

7) Right click on the "File Import" node and choose "Edit Variables" to set the roles and levels for the variables in the dataset.
 

 

New Contributor
Posts: 4

Re: File Import in SAS Enterprise Miner

Why this one comes when i try to import .xls file to Enterprise Miner :

But its full of data


sas.jpg
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 1721 views
  • 0 likes
  • 4 in conversation