SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

same PASS through code works on one SAS server, but not the other one, what's the possible reason?

Reply
Regular Contributor
Posts: 167

same PASS through code works on one SAS server, but not the other one, what's the possible reason?

Hi All,

 

    I have one testing SAS server and one production SAS server. I tested the pass through to SQL data connection coding, it works on testing server, but not on production SAS server, I wonder what is the possible reason.

 

   Config: Same ODBD.ini file on both SAS servers(testing and production).

                Same coding

  

The coding is as below:

  

proc sql;

connect to odbc (noprompt = "dsn=**;DRIVER=SQLServer;uid=**;pwd=**;");

create table test as

select * from connection to odbc

(SELECT *

FROM [**].[**].[**]

)

;

disconnect from odbc;

quit;

 

The Error for the production server is as beow:

ERROR: CLI describe error: [

NOTE: PROC SQL set option NOEXEC and will continue to check the syntax of statements.

 disconnect from odbc;

NOTE: Statement not executed due to NOEXEC option.

quit;

NOTE: The SAS System stopped processing this step because of errors.

 

 

Thank you!

Jade

Regular Contributor
Posts: 167

Something to add

1)  if I try libname at schema level, the table show in TESTing is the same at SQL studio, see attachment TEST.

 LIBNAME sqltest odbc Password=** User=** DATASRC=** schema=dbo;

 

 2) if  if I try libname at schema level in Production server,  the table show in Production seems have chopped name (in my case, the table only have letter s, whihc is the initial letter of those tables in TEST server), see attachment PROD.


TEST.png
Regular Contributor
Posts: 167

PROD table is attached

PROD table seems have chopped name from tables in TESTing server


PROD.png
Ask a Question
Discussion stats
  • 2 replies
  • 137 views
  • 0 likes
  • 1 in conversation