SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

Teradata column bigint is not showing in SAS

Reply
Occasional Contributor
Posts: 7

Teradata column bigint is not showing in SAS

[ Edited ]

There is a table in Teradata which has bigint column, those columns aren't accessible from SAS. Is there any option to get access that columns from SAS EG 7.12

SAS Employee
Posts: 200

Re: Teradata column bigint is not showing in SAS

Hi @anlyar2050

 

SAS cannot read the BIGINT data types, directly. There are a couple of ways to handle it.

 

The first is to have your DBA create views which CAST the BIGINT columns to a character data type (Linus' recommendation). You can do this, without creating Teradata views, using explicit pass-thru.

 

I have pulled some slides covering using SAS with Teradata BIGINT from a workshop that I used to deliver. Hopefully, they will help. If the slides require clarification please let me know.

Teradata_BIGINT_01.jpg

 

 

 

Teradata_BIGINT_02.jpg

 

 

Teradata_BIGINT_03.jpg

 

 

Teradata_BIGINT_04.jpg

 

 

Teradata_BIGINT_05.jpg

 

Be careful with TRUNCATE_BIGINT. Doing calculations using BIGINT columns could very well be problematic because you can get incorrect answers.

 

http://support.sas.com/kb/39/831.html

Occasional Contributor
Posts: 7

Re: Teradata column bigint is not showing in SAS

thanks for the reply.

I understand this but users usually won't do coding they will use tables and do query builder. So where can we set truncate_bigint to Yes? So that they can use tables in query builder instead of coding.

Super User
Posts: 5,254

Re: Teradata column bigint is not showing in SAS

Agree that it's not very clear in the usage note, but I found a little more specific description in the ACCESS to Netezza doc:

"suppress the errors by setting the TRUNCATE_BIGINT environment variable to YES before you start SAS."
Data never sleeps
Occasional Contributor
Posts: 7

Re: Teradata column bigint is not showing in SAS

Thanks for the reply.

 

I understand to set the TRUNCATE_BIGINT environment variable to YES, but I don't understand is where to set environmental variable?

 

Thanks.

Super User
Posts: 5,254

Re: Teradata column bigint is not showing in SAS

It depends on how/where your SAS session is/starts. Generally you could either use a SET instruction in a config file, or have it set in operating system, for your user or globally. You might sent to talk to your SAS responsible/admin or platform team for on site guidance.
Data never sleeps
Ask a Question
Discussion stats
  • 5 replies
  • 370 views
  • 0 likes
  • 3 in conversation