SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

Schedule error while successful tests in DIS

Accepted Solution Solved
Reply
Contributor
Posts: 21
Accepted Solution

Schedule error while successful tests in DIS

Hi,

 

I have a data job that runs ok in DIS, when executed over and over again.

 

Now I'm trying to schedule it but some errors come up, that are completely new. Please see attached the log that I obtain from the server.

 

The very first error that appears in the log is the following:

 

ERROR 180-322: Statement is not valid or it is used out of proper order.

 

How come an error show up with the schedule if the executions in DIS show no problem?

 

Please let me know your thoughts,

 

Martin


Accepted Solutions
Solution
‎06-19-2018 01:06 PM
Respected Advisor
Posts: 4,791

Re: Schedule error while successful tests in DIS

Posted in reply to mchiappe83

@mchiappe83

If you chose for your job "Collect Runtime Statistics" then the macro definition for  %etls_setPerfInit; gets directly generated into the code for the DIS job.

If "Collect Runtime Statistics" hasn't been chosen then this macro gets neither defined nor used in the generated code.

 

If you've got code which uses the macro without it being defined in the same job code then I'd assume that "someone" modified the code after deploying the job.

 

To fix this: 

1. Redeploy your DIS job.

2. Make sure that the scheduler uses the deployment object which you've used to redeploy your job

3. Rerun code via scheduler.

 

Let us know if this resolved your problem.

 

View solution in original post


All Replies
PROC Star
Posts: 1,334

Re: Schedule error while successful tests in DIS

Posted in reply to mchiappe83

The problem appears to be that a macro isn't being found. I suspect there's some difference in the environment where you're trying to run now and the one where it used to work that a macro library isn't available, or the SAS options have changed.

 

Tom

Solution
‎06-19-2018 01:06 PM
Respected Advisor
Posts: 4,791

Re: Schedule error while successful tests in DIS

Posted in reply to mchiappe83

@mchiappe83

If you chose for your job "Collect Runtime Statistics" then the macro definition for  %etls_setPerfInit; gets directly generated into the code for the DIS job.

If "Collect Runtime Statistics" hasn't been chosen then this macro gets neither defined nor used in the generated code.

 

If you've got code which uses the macro without it being defined in the same job code then I'd assume that "someone" modified the code after deploying the job.

 

To fix this: 

1. Redeploy your DIS job.

2. Make sure that the scheduler uses the deployment object which you've used to redeploy your job

3. Rerun code via scheduler.

 

Let us know if this resolved your problem.

 

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 151 views
  • 0 likes
  • 3 in conversation