SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

SAS Data Integration Studio: Disallow a user to run a job

Accepted Solution Solved
Reply
Contributor
Posts: 38
Accepted Solution

SAS Data Integration Studio: Disallow a user to run a job

[ Edited ]

I have set permission that user A could only readmetadata on a folder. However, user A could still execute the jobs inside the folder.

 

Meanwhile, is it able to disable the run tab, i.e, the arrow of run would become un-clickable.

run.jpg, like the "stop tab".

 

Or,

Can I assign who can run a specific job?

 

Thanks for any help.


Accepted Solutions
Solution
‎04-21-2017 12:29 AM
Super User
Posts: 5,255

Re: SAS Data Integration Studio: Disallow a user to run a job

If that's your requirement have the jobs in a separate folder and have only the persons that should be able to execute jobs read access.
Be aware that you need to consider deployed jobs as well (including the .Sas files).
Again, it feels simpler to secure the data instead.
Data never sleeps

View solution in original post


All Replies
Super User
Posts: 5,255

Re: SAS Data Integration Studio: Disallow a user to run a job

No, I don't think that is possible by simple metadata authorization settings.
So you want a user to look at a job but not to execute it. Why is that?
If you want to prevent unauthorised modification of data you need to set authorization on the target tables.
Data never sleeps
Contributor
Posts: 38

Re: SAS Data Integration Studio: Disallow a user to run a job

really? The origiinal idea is that someone could run particular job in the folder. 

Solution
‎04-21-2017 12:29 AM
Super User
Posts: 5,255

Re: SAS Data Integration Studio: Disallow a user to run a job

If that's your requirement have the jobs in a separate folder and have only the persons that should be able to execute jobs read access.
Be aware that you need to consider deployed jobs as well (including the .Sas files).
Again, it feels simpler to secure the data instead.
Data never sleeps
☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 235 views
  • 2 likes
  • 2 in conversation