SAS Data Integration Studio, DataFlux Data Management Studio, SAS/ACCESS, SAS Data Loader for Hadoop and others

SAS 9.1 and Oracle 12C compatibility - Is it possible?

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 16
Accepted Solution

SAS 9.1 and Oracle 12C compatibility - Is it possible?

Hi everyone,

 

I was questioned about the possibility and compatibility of migrating the Oracle version from 11 to 12C, in a 9.1 version of SAS, which is in use at this moment.

 

I know this version is outdated and no longer supported by SAS, and that the normal answer will be to upgrade the system or to not relly on an old SAS version to keep up with a new Oracle Version, but did anyone tried this?

 

We don't have anything too complex in terms of Oracle in our SAS DIS, and regarding the ODBC that SAS uses in this version, could it be used with Oracle 12c?

 

Best regards and thanks everyone.


Accepted Solutions
Solution
‎11-07-2016 06:05 AM
SAS Employee
Posts: 203

Re: SAS 9.1 and Oracle 12C compatibility - Is it possible?

Hi @aiaimanel,

 

SAS 9.1.3 is 9 years old. When it was released it was base-lined on Oracle 8.1.7. This is a very old version of Oracle. Typically, we support the baseline plus two major releases. Using this formula we come to the unfortunate conclusion that SAS 9.1.3 does not support Oracle 12c. Keep in mind, this doesn't mean that it won't work. It means that if you have a problem there is little chance of Tech Support being able to help you. As you mention in your post, SAS 9.1.3 is not supported either... so, this is moot.

 

There is a chance that this will work. I have never tried it and I haven't heard of others trying it. Your best bet is to use an Oracle 11g client for the connection to 12c. That may work, but there are no guarantees.

 

Good luck,

Jeff

 

PS. I feel compelled to suggest upgrading your SAS environment... Now I feel betterSmiley Wink

View solution in original post


All Replies
Solution
‎11-07-2016 06:05 AM
SAS Employee
Posts: 203

Re: SAS 9.1 and Oracle 12C compatibility - Is it possible?

Hi @aiaimanel,

 

SAS 9.1.3 is 9 years old. When it was released it was base-lined on Oracle 8.1.7. This is a very old version of Oracle. Typically, we support the baseline plus two major releases. Using this formula we come to the unfortunate conclusion that SAS 9.1.3 does not support Oracle 12c. Keep in mind, this doesn't mean that it won't work. It means that if you have a problem there is little chance of Tech Support being able to help you. As you mention in your post, SAS 9.1.3 is not supported either... so, this is moot.

 

There is a chance that this will work. I have never tried it and I haven't heard of others trying it. Your best bet is to use an Oracle 11g client for the connection to 12c. That may work, but there are no guarantees.

 

Good luck,

Jeff

 

PS. I feel compelled to suggest upgrading your SAS environment... Now I feel betterSmiley Wink

Occasional Contributor
Posts: 16

Re: SAS 9.1 and Oracle 12C compatibility - Is it possible?

Thank you for your answer.
Although in this particular case there is no "right solution" and the only way is testing, I'm going to accept your reply as the solution.

PS: I hope you feel better with the upgrade suggestion, I also feel the same whenever I come across a bug in this version.
Respected Advisor
Posts: 3,887

Re: SAS 9.1 and Oracle 12C compatibility - Is it possible?

in terms of Oracle in our SAS DIS,

 

...and in regards of upgradel: If you're on SAS9.1.3 then you have still to use DIS3.4. If so then it's really time to upgrade as the changes and improvements to DIS 4.x increased usability and productivity quite a bit.

Occasional Contributor
Posts: 16

Re: SAS 9.1 and Oracle 12C compatibility - Is it possible?

Thank you for your reply.

And can I upgrade the DIS Version in this case? Or do I need to upgrade all SAS ?
SAS Employee
Posts: 203

Re: SAS 9.1 and Oracle 12C compatibility - Is it possible?

Hi @aiaimanel,

 

You would have to upgrade all of SAS because DI Studio will use the underlying SAS/ACCESS components and they are what limiting you here.

 

Hope this helps!

Jeff

Occasional Contributor
Posts: 16

Re: SAS 9.1 and Oracle 12C compatibility - Is it possible?

Thanks so much Jeff, I will look it up!
☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 6 replies
  • 480 views
  • 3 likes
  • 3 in conversation